rospeex audio_monitor not working

asked 2016-02-26 13:53:09 -0500

tgibbons gravatar image

I am trying to use the current version of rospeex on a Tutrtlebot 2 running Ubuntu 14.04 Trusty and ROS Indigo. I have tried the apt package install and also the complied from the current source.

In all cases I am having problems with the audio monitor when I run rosrun rospeex_audiomonitor audio_monitor_epd

The audio monitor window starts up and displays the waveform from the mic, but soon turns gray and become inactive, that is non of the UI works. The console dislays:

   state= 0

I have been going through the related launch files and source files and cannot see anything wrong. I have also tried different microphone sources.

This has worked vary briefly once, but that is not repeatable. This makes me worried it is something with the rospeex server since this is a cloud based solution.

Is anyone else using rospeex currently and can verify that the service is up?

I have considered switching to the Google speed API listed in the source code, but this seems to have been discontinued since I don't see it listed in my available Google APIs.

Any suggestions on what else to try or other speech recognition systems for ROS?

edit retag flag offensive close merge delete