Ask Your Question
0

Adding RPLIDAR_ROS as package dependency.

asked 2016-02-19 18:00:19 -0600

JSR694 gravatar image

Hi all,

I'm trying to catkin_make a new package, with the rplidar_ros package as a dependency. However, when I run catkin_make, I get the following error:

CMake Error at /opt/ros/indigo/share/catkin/cmake/catkinConfig.cmake:75 (find_package):
  Could not find a package configuration file provided by "rplidar_ros/" with
  any of the following names:

    rplidar_ros/Config.cmake
    rplidar_ros/-config.cmake

  Add the installation prefix of "rplidar_ros/" to CMAKE_PREFIX_PATH or set
  "rplidar_ros/_DIR" to a directory containing one of the above files.  If
  "rplidar_ros/" provides a separate development package or SDK, be sure it
  has been installed.
Call Stack (most recent call first):
  ugv_2dnav/CMakeLists.txt:7 (find_package)

System info: Ubuntu 14.04, ROS Indigo, rplidar_ros version 1.01

The rplidar_ros package was successfully cloned and catkin_make-d before I attempted to create this new package. I'm stumped! Any help would be greatly appreciated.

Cheers! Jack

edit retag flag offensive close merge delete

Comments

Where did you clone the rplidar package from? Was it the cob_substitute repo listed on the ROS wiki rplidar_ros page, or was it from robopeak? I cloned from the robopeak repo and never had any issues.

Steven_Daniluk gravatar imageSteven_Daniluk ( 2016-02-20 09:30:52 -0600 )edit

My apologies for the delay in response! I cloned robopeak's repo. Again, I could run their demo just fine; problems only arose when trying to make a package with rplidar+ros as a dependency. The problem was resolved by Akif, but thanks for your help!

JSR694 gravatar imageJSR694 ( 2016-02-25 17:31:57 -0600 )edit

1 Answer

Sort by ยป oldest newest most voted
3

answered 2016-02-21 04:34:42 -0600

Akif gravatar image

Seems like there is an error with package name. "rplidar_ros/" should be "rplidar_ros" (note the trailing slash). Maybe you have a typo.

edit flag offensive delete link more

Comments

Yes, this was the problem! A silly mistake :. Thanks for your help!

JSR694 gravatar imageJSR694 ( 2016-02-25 17:33:00 -0600 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2016-02-19 18:00:19 -0600

Seen: 535 times

Last updated: Feb 21 '16