Ask Your Question
0

ros urdf tutorial on osx

asked 2016-02-13 07:20:44 -0500

jacksonkr_ gravatar image

I did some of the turtle sim tutorials and now I'm trying to do an urdf tutorial but I'm running into some issues. What's going on here?

$ roslaunch urdf_tutorial display.launch model:='$(find urdf_tutorial)/urdf/01-myfirst.urdf'
... logging to /Users/Jackson/.ros/log/0b166d51-d251-11e5-96bf-a0999b17aec5/roslaunch-lapfeet.local-1073.log
Checking log directory for disk usage. This may take awhile.
Press Ctrl-C to interrupt

started roslaunch server http://lapfeet.local:51266/

SUMMARY
========

PARAMETERS
 * /robot_description: <?xml version="1....
 * /rosdistro: indigo
 * /rosversion: 1.11.16
 * /use_gui: False

NODES
  /
    joint_state_publisher (joint_state_publisher/joint_state_publisher)
    robot_state_publisher (robot_state_publisher/state_publisher)
    rviz (rviz/rviz)

ROS_MASTER_URI=http://localhost:11311

core service [/rosout] found
process[joint_state_publisher-1]: started with pid [1078]
ERROR: cannot launch node of type [robot_state_publisher/state_publisher]: can't locate node [state_publisher] in package [robot_state_publisher]
ERROR: cannot launch node of type [rviz/rviz]: can't locate node [rviz] in package [rviz]
Traceback (most recent call last):
  File "/Users/Jackson/ros_catkin_ws/src/robot_model/joint_state_publisher/joint_state_publisher/joint_state_publisher", line 5, in <module>
    import wx
ImportError: No module named wx
[joint_state_publisher-1] process has died [pid 1078, exit code 1, cmd /Users/Jackson/ros_catkin_ws/src/robot_model/joint_state_publisher/joint_state_publisher/joint_state_publisher __name:=joint_state_publisher __log:=/Users/Jackson/.ros/log/0b166d51-d251-11e5-96bf-a0999b17aec5/joint_state_publisher-1.log].
log file: /Users/Jackson/.ros/log/0b166d51-d251-11e5-96bf-a0999b17aec5/joint_state_publisher-1*.log
all processes on machine have died, roslaunch will exit
shutting down processing monitor...
... shutting down processing monitor complete
done
edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
0

answered 2016-02-13 11:08:19 -0500

gvdhoorn gravatar image
ERROR: cannot launch node of type [robot_state_publisher/state_publisher]: can't locate node [state_publisher] in package [robot_state_publisher]
ERROR: cannot launch node of type [rviz/rviz]: can't locate node [rviz] in package [rviz]
Traceback (most recent call last):
  File "/Users/Jackson/ros_catkin_ws/src/robot_model/joint_state_publisher/joint_state_publisher/joint_state_publisher", line 5, in <module>
    import wx
ImportError: No module named wx

Just making sure: have you sourced the correct setup.bash / workspace? These error messages point to some issues with the environment you are trying to start the launch file in (not being able to find rviz fi).

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2016-02-13 07:20:44 -0500

Seen: 368 times

Last updated: Feb 13 '16