Ask Your Question
0

ros-jade-desktop-full not setting up ros or gazebo setup files properly

asked 2016-02-11 17:05:18 -0600

dcconner gravatar image

updated 2016-02-12 17:16:33 -0600

Normally, after an install of ros-jade-desktop-full on Ubuntu 14.04.3 LTS (trusty) 64-bit, the gazebo 5.0 package is setup to run properly.

I tried to set up a new computer this afternoon, and it is giving me an error because there is no /usr/share/gazebo library.

I know this was working a couple of weeks ago. Has there been a change to debs that busted this?

Attached is screen shot of result: image description

This after apt-get removing prior attempts, apt-get updating/upgrading, and rebooting. I started install of ros-jade-desktop-full, and redirected to file. The install seems to complete without error, but I have no /usr/share/gazebo folder and no setup files in the /opt/ros/jade folder

edit retag flag offensive close merge delete

Comments

Could you edit your post to include the full error that you are seeing?

gvdhoorn gravatar imagegvdhoorn ( 2016-02-12 01:53:23 -0600 )edit

Normally, the install creates a /usr/share/gazebo-5.0 folder with models and code, and a /usr/share/gazebo folder with setup script that points to the appropriate version of gazebo.

You need to source this to run gazebo stand alone. This folder is not being created.

dcconner gravatar imagedcconner ( 2016-02-12 08:43:41 -0600 )edit

This morning I removed (sudo apt-get remove ) ros-jade-desktop-full, and tried to re-install. Now the setup script in /opt/ros/jade is missing.

dcconner gravatar imagedcconner ( 2016-02-12 08:44:49 -0600 )edit

In my prior (last couple of weeks) installs of ros-jade-desktop-full, it installed gazebo-5.1. Now I notice that it installed 5.0 this morning.

dcconner gravatar imagedcconner ( 2016-02-12 09:21:49 -0600 )edit

I filed a ticket https://github.com/ros/rosdistro/issu... in case this is some widespread issue.

dcconner gravatar imagedcconner ( 2016-02-12 09:57:16 -0600 )edit

I'm a bit confused: is the issue with Gazebo or with ROS? Your question title suggests Gazebo isn't being installed correctly, but your comments suggest you are encountering some issues with ROS itself. For the former, I'd suggest reporting to the Gazebo people, the latter we can deal with here.

gvdhoorn gravatar imagegvdhoorn ( 2016-02-12 10:43:24 -0600 )edit

As posted on the rosdistro ticket. This started as an issue with the Gazebo5 package embedded in the ROS jade desktop full. After removing and trying a fresh install of ROS this morning, I have an issue with both Gazebo and /opt/ros/jade setup files missing.

dcconner gravatar imagedcconner ( 2016-02-12 12:16:51 -0600 )edit

What does dpkg -l | grep ros-jade-catkin output?

Dirk Thomas gravatar imageDirk Thomas ( 2016-02-12 17:24:10 -0600 )edit

1 Answer

Sort by ยป oldest newest most voted
0

answered 2016-02-12 06:37:04 -0600

I was installing ROS Jade in this morning too...

When I installed the distribution, I tried to run gazebo command and it was launched successfully. But, I got an error when I stopped to run Gazebo. I figured out that I didnt set up smth, so I followed to this and Gazebo works fine now.

edit flag offensive delete link more

Comments

Are you saying you installed ros, and then manually installed gazebo? Which version? Jade normally uses Gazebo5, but those instructions are for gazebo7.

I tried reinstalling jade this morning, and not the setup script that is supposed to be in /opt/ros/jade is missing.

dcconner gravatar imagedcconner ( 2016-02-12 08:40:51 -0600 )edit

Gazebo 5.1.0. I installed first ros and the folders gazebo_msgs, gazebo_plugins, gazebo_ros, gazebo_ros_pkgs appeared in /opt/ros/jade/share. I ran Gazebo after and it opened successfully. But, I decided to visit gazebo tutorials and I foun

dyupleks gravatar imagedyupleks ( 2016-02-12 23:22:19 -0600 )edit

... I found that gazebo_ros_pkgs should be in catkin_ws.

dyupleks gravatar imagedyupleks ( 2016-02-12 23:23:24 -0600 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

2 followers

Stats

Asked: 2016-02-11 17:05:18 -0600

Seen: 158 times

Last updated: Feb 12 '16