ROS Resources: Documentation | Support | Discussion Forum | Index | Service Status | ros @ Robotics Stack Exchange
Ask Your Question

Jenkins build became unstable - what am I supposed to do?

asked 2016-02-11 11:24:18 -0600

Sabrina gravatar image

updated 2016-02-11 12:23:51 -0600


I just released a new version of an existing package. Before the release I ran the prerelease test successfully.

Now I got an email from the ROS Buildfarm with the subject: "Jenkins build became unstable: [...]"

edit: Here is the link contained in the email:

What am I supposed to do? Is this critical?

Regards, Sabrina

edit retag flag offensive close merge delete


If you include the link to the actual job in the question you might get a more helpful answer.

Dirk Thomas gravatar image Dirk Thomas  ( 2016-02-11 12:04:05 -0600 )edit

thanks for the hint - > I added the link.

Sabrina gravatar image Sabrina  ( 2016-02-11 12:26:45 -0600 )edit

2 Answers

Sort by ยป oldest newest most voted

answered 2016-02-11 12:53:53 -0600

Dirk Thomas gravatar image

The devel job is building your source code when you commit any changes to the branch specified in the source section of rosdistro (after some delay, commonly checking once every hour).

If you read through the console output ( ) you will find the section where the tests are being run ( ). The test checking the roslaunch file fails with a stacktrace.

Based on that you will find the test results at the end which say:

The total number of tests for this category exceeds the specified 'unstable' threshold value.
Setting the build status to UNSTABLE

That's why the build was marked as unstable and you received a notification email. You can also see the summary of all tests here:

Now to reason why the test might fail. The stacktrace says: rospkg.common.ResourceNotFound: gazebo_ros My first guess would be that your launch file uses something from the gazebo_ros package but since your package.xml file doesn't declare a dependency on that package it is not available on the build farm. That also means if someone if installing your Debian package and tried to run the launch file it would fail in a similar way. Therefore you will likely have to add a run dependency on gazebo_ros to make this test pass and the Debian package usable.

edit flag offensive delete link more


Thank you, now I see. The problem is exactly as you said: I removed run deps concerning gazebo from package.xml because this resolves in system dependencies of Gazebo2 in the resulting debian package. But I need Gazebo6 in order get a correctly running robot model with this package.

Sabrina gravatar image Sabrina  ( 2016-02-11 15:39:48 -0600 )edit

In fact this is related with my other question:

Sabrina gravatar image Sabrina  ( 2016-02-11 15:41:01 -0600 )edit

Can I ignore the fact that the build is unstable until I found a way to include gazebo6 as run dep? Or could anything be harmed as long as the build is unstable?

Sabrina gravatar image Sabrina  ( 2016-02-11 15:44:14 -0600 )edit

As a workaround I removed the line roslaunch_add_file_check(launch) from the CMakeLists.txt. The build is stable now. But users will have to install ros-indigo-gazebo6 and ros-indigo-gazebo6-plugins manually to be able to run the launch files.

Sabrina gravatar image Sabrina  ( 2016-03-03 02:18:40 -0600 )edit

answered 2016-02-11 11:47:48 -0600

dornhege gravatar image

The email usually contains an email with the jenkins link to the build logs. Check if it's your fault or it is something that needs fixing. If in doubt write to the ros-release mailing list.

edit flag offensive delete link more

Question Tools

1 follower


Asked: 2016-02-11 11:24:18 -0600

Seen: 10,767 times

Last updated: Feb 11 '16