Ask Your Question
1

OSX rgbdslam install via indigo

asked 2016-02-03 13:37:53 -0600

jacksonkr_ gravatar image

updated 2016-04-10 07:38:22 -0600

#On Hold

Holding off on rgbdslam install to El Capitan until ros libs progress for osx 10.11+

interim solution was to install rgbdslam v2 via ros indigo + Ubuntu 14.04 + rEFind for osx


ROS Indigo took some work to install on OSX El Captian (10.11.3) but it works now.

At this point I can attempt to install rgbdslam

$ rosdep install rgbdslam

But I'm getting the following error:

$ rosdep install rgbdslam
ERROR: the following packages/stacks could not have their rosdep keys resolved
to system dependencies:
rgbdslam: No definition of [libdevil-dev] for OS [osx]

I have devIL installed via brew:

$ brew install devil
Warning: devil-1.7.8_1 already installed

At this point I'm stuck. What should I do?

* EDIT *

  • Tried installing libdevil from source, unsuccessfully.
  • Installed libdevil via macports. Didn't help so I uninstalled macports since brew is my preferred package manager.

* EDIT *

  • Set siftgpu_disable_devil = 0 in SiftGPU/makefile
  • set(ENV{SIFT_GPU_MODE} 0) in CMakeLists.txt

I'm still seeing rgbdslam: No definition of [libdevil-dev] for OS [osx]

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
0

answered 2016-02-04 08:12:42 -0600

Try removing the dependency from rgbdslam/package.

Should you get compilation/linking problems, try to set the CMake-Variable USE_SIFT_GPU to 0 (e.g., using cmake-gui). SiftGPU is the thing in rgbdslam that needs libdevil

edit flag offensive delete link more

Comments

I set siftgpu_disable_devil = 0 in SiftGPU/makefile and set(ENV{SIFT_GPU_MODE} 0) in CMakeLists.txt with no avail. I'm still seeing rgbdslam: No definition of [libdevil-dev] for OS [osx]

jacksonkr_ gravatar imagejacksonkr_ ( 2016-02-06 08:18:45 -0600 )edit
1

And have you removed the dependency in package.xml?

Felix Endres gravatar imageFelix Endres ( 2016-02-08 08:46:28 -0600 )edit

Commenting devIL out in package.xml put me a little further but into some seemingly OSX specific issues, trying to resolve those via github. Will respond here once I have a solution. Thanks for your assistance.

jacksonkr_ gravatar imagejacksonkr_ ( 2016-02-08 11:08:39 -0600 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2016-02-03 13:37:53 -0600

Seen: 205 times

Last updated: Apr 10 '16