remote core with move group

asked 2016-01-29 09:15:04 -0500

Sietse gravatar image

updated 2016-02-05 07:58:09 -0500

Hello list,

Using the examples from ROS by Example vol. 1, chapter 8.2, I try to use move_group. After starting with

roslaunch rbx1_bringup fake_turtlebot.launch

Then

roslaunch rbx1_nav fake_move_base_blank_map.launch

This works perfectly using the regular PC that I use for ROS. But when I do these 2 commands on a remote computer (ARM-based, ubuntu.14.04), the last command hangs half way and some topics a missing. When I run roscore also on that remote computer, so everything is running there, then all is well again.

The remote computer has also been installed with indigo, and the workspace to use is a copy of the one on my PC, it also contains the rbx1-code.

Here a few of the topics that are missing when roscore is not on the same machine.

/move_base/TrajectoryPlannerROS/cost_cloud
/move_base/TrajectoryPlannerROS/global_plan
/move_base/local_costmap/costmap
/move_base/local_costmap/costmap_updates

Also the move_group launch hangs after few lines of output, it ends with:

[ INFO] [1454075003.413349751]: Using plugin "obstacle_layer"
[ INFO] [1454075003.418332874]:     Subscribed to Topics: scan
[ INFO] [1454075003.456309904]: Using plugin "inflation_layer"

and then nothing. If roscore is running on the same machine the output continues with the following:

[ INFO] [1454075003.732102374]: Loading from pre-hydro parameter style
[ INFO] [1454075003.768873800]: Using plugin "static_layer"

and finally ends with:

[ INFO] [1454075005.067875908]: odom received!

Why is there such difference between the 2 situations? Note that the code runs correct on both machines when roscore is running also on that same machine.

Edit: I forgot to mention that when I end the hung program with Ctrl-C I get the following:

[ERROR] [1454076466.308442381]: [registerPublisher] Failed to contact master at [129.125.16.202:11311].  Retrying...
^C[move_base-2] escalating to SIGTERM

Why should that happen when I, e.g. still can use rostopic echo on both sides?

===2-nd edit====

I checked that basic communication between rosnodes on the two hosts work, so simple stuff works, but the problem still remains.

If I start move_base on the main host (where roscore runs), everything works, I can give 2D-goals in rviz, great! But if I start move_base on the arm-host a number of topics (mainly to to with local_costmap) do not appear. And the Inflated Obstacles plugin of Rviz complains: No map received and No transform from [] to [map]

And when I Ctrl-C the hung program i stll get:

[ERROR] [1454076466.308442381]: [registerPublisher] Failed to contact master at [192.168.1.100:11311].

But rostopic list etc. still works there.

Note that I have the same "local" workspace on both the hosts next to /opt/ros/indigo. Anything to to with that?

====== final edit ========

I switched to another PC as the base machine, and the problem does not occur anymore. I dont see any difference between the machines, but I am closing this question because it probably has something to do with the installation of the one PC.

Thanks for the help, Sietse

edit retag flag offensive close merge delete

Comments

Have you solved your previous question? There could be a chance they are related.

gvdhoorn gravatar imagegvdhoorn ( 2016-01-29 14:24:40 -0500 )edit

Is there a way to paste more than one line into this message which preformat? I now had to do it line by line.

Yes, just select the code you want to format, then pres ctrl+k.

gvdhoorn gravatar imagegvdhoorn ( 2016-01-29 14:25:16 -0500 )edit

I thought I did, but please see the "edit" in my question.

Sietse gravatar imageSietse ( 2016-01-29 15:15:48 -0500 )edit

I'm a bit confused: did you or did you not solve your previous question? If you did, could you please tell us what you did to solve it (or accept the given answer(s) if that is what you did)? It's rather hard figuring out what the current status of your system is otherwise.

gvdhoorn gravatar imagegvdhoorn ( 2016-01-30 10:38:58 -0500 )edit

Thanks for the reply. As I said, I thought I did. I will do more tests on Monday and hopefully find out one or the other.

Sietse gravatar imageSietse ( 2016-01-30 13:20:13 -0500 )edit

Please don't delete this question. It is a valid issue, and perhaps some other user runs into it in the future.

gvdhoorn gravatar imagegvdhoorn ( 2016-02-05 08:12:18 -0500 )edit

I am a bit confused here. Should this question be marked as answered or should I just leave it as it is now?

Sietse gravatar imageSietse ( 2016-02-05 08:41:05 -0500 )edit

Well I don't think it's really answered, as you basically worked around the problem by going to a different machine. You could perhaps migrate your final edit to an answer, but then leave the question unanswered.

gvdhoorn gravatar imagegvdhoorn ( 2016-02-05 08:58:30 -0500 )edit