Ask Your Question
0

Robot Upstart and USB Ports

asked 2016-01-26 21:42:49 -0500

Waron gravatar image

I'm currently trying to create a robot upstart package for my turtlebot 1.0. Seeing as how the minimal.launch relies on environment variables to launch the proper nodes for the turtlebot 1.0, I created a separate package in my workspace with the only purpose of having a launchfile for starting the turtlebot for the create base and kinect. The upstart package worked, and ros starts and so do all of the nodes, except the create isn't connected.

I think the problem is getting robot_upstart permission to use ttyUSB0. I created a udev rule to give permission to everyone, but I'm not sure if that's working? Has anybody faced a similar problem?

Thanks for any help or suggestions.

edit retag flag offensive close merge delete

Comments

Have you read the note about permissions set/used for the user robot_upstart uses? See The install script - permissions in the docs.

gvdhoorn gravatar imagegvdhoorn ( 2016-01-27 02:25:44 -0500 )edit

I tried installing the job with the --user root option, but I still can't get it to connect. I tried setting udev rules and running as a variety of users. I did read the script, and I thought running as root or setting a udev is what they were indicated, but perhaps I'm misunderstanding something?

Waron gravatar imageWaron ( 2016-01-27 13:42:12 -0500 )edit

Can you post the udev rule and the part where you launch the turtlebot also dose the launch file work when you start manually

Peter Heim gravatar imagePeter Heim ( 2016-01-27 14:31:12 -0500 )edit

For the udev rule, I made a file called "99-my-usb.rules" in /etc/udev/rules.d. The file contains the line: KERNEL=="ttyUSB[0-9]*,GROUP="uucp",MODE="0666"

I've also tried editing the rule for strictly USB0, with and without the GROUP, but always keeping the mode 666.

Waron gravatar imageWaron ( 2016-01-27 14:43:24 -0500 )edit

As for the launch file, it works perfectly when manually launched. All it does is call the turtlebot minimal.launch file with the parameters for my turtlebot 1.0.

Waron gravatar imageWaron ( 2016-01-27 14:44:19 -0500 )edit

1 Answer

Sort by ยป oldest newest most voted
0

answered 2016-01-26 23:28:44 -0500

Peter Heim gravatar image

What version of ROS are you using and have you checked the log for errors??

edit flag offensive delete link more

Comments

I'm using Indigo. I checked the logs but I can't seem to find any errors relating to inability to connect. Usually when the create is unable to connect it gives an error indicating SCI can't connect, but here I'm not getting anything.

Waron gravatar imageWaron ( 2016-01-27 13:40:30 -0500 )edit

I lied! The console is showing warnings "Create : robot not connected yet, sci not available" when robot_upstart calls the launchfile.

Waron gravatar imageWaron ( 2016-01-27 15:13:03 -0500 )edit

I'm not familiar with sic but i would check its permissions as a start, look for env variables i think upstart runs as a different user

Peter Heim gravatar imagePeter Heim ( 2016-01-27 15:33:49 -0500 )edit

So, I've been able to confirm now that my udev rules are working, and I'm able to give ttyUSB0 permissions to the "users" group, which should cover even the unprivileged users ran by setuidgid program which calls the launchfile. I still get error messages that the create isn't connect however. :(

Waron gravatar imageWaron ( 2016-01-27 22:37:19 -0500 )edit

also, the sci is just the serial interface it uses... when I run the launchfile on its own, and I've chowned ttyUSB0 prior, it connects just fine and everything works.

Waron gravatar imageWaron ( 2016-01-27 22:38:23 -0500 )edit
1

are you using udev to change permissions for USB0? I use symlink as so SUBSYSTEMS=="usb", KERNEL=="ttyUSB[0-9]*", ATTRS{idVendor}=="0403", ATTRS{idProduct}=="6001", SYMLINK+="sensors/ftdi_%s{serial}"

Peter Heim gravatar imagePeter Heim ( 2016-01-27 23:00:37 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2016-01-26 21:42:49 -0500

Seen: 620 times

Last updated: Jan 26 '16