Ask Your Question
0

ROS rgbdslam not working as expected

asked 2016-01-16 10:13:29 -0500

jacksonkr_ gravatar image

updated 2016-01-16 10:29:42 -0500

It's my first time with ros and I installed using the RGB-D SLAM for "Not-yet" ROS Users (bottom of the page)

I'm able to run the following but no GUI shows up so after a few minutes of sitting there I ctrl+c. Am I missing something?

$ roslaunch rgbdslam kinect+rgbdslam.launch
... logging to /home/jackson/.ros/log/65d80698-bc6b-11e5-a420-000c29347746/roslaunch-ubuntu-4488.log
Checking log directory for disk usage. This may take awhile.
Press Ctrl-C to interrupt
Done checking log file disk usage. Usage is <1GB.

started roslaunch server http://ubuntu:55220/

SUMMARY
========

PARAMETERS
 * /camera/depth/rectify_depth/interpolation
 * /camera/depth_registered/rectify_depth/interpolation
 * /camera/disparity_depth/max_range
 * /camera/disparity_depth/min_range
 * /camera/disparity_depth_registered/max_range
 * /camera/disparity_depth_registered/min_range
 * /camera/driver/depth_camera_info_url
 * /camera/driver/depth_frame_id
 * /camera/driver/depth_registration
 * /camera/driver/device_id
 * /camera/driver/rgb_camera_info_url
 * /camera/driver/rgb_frame_id
 * /rgbdslam/config/backend_solver
 * /rgbdslam/config/feature_detector_type
 * /rgbdslam/config/feature_extractor_type
 * /rgbdslam/config/g2o_transformation_refinement
 * /rgbdslam/config/gicp_max_cloud_size
 * /rgbdslam/config/icp_method
 * /rgbdslam/config/max_keypoints
 * /rgbdslam/config/min_matches
 * /rgbdslam/config/min_rotation_degree
 * /rgbdslam/config/min_sampled_candidates
 * /rgbdslam/config/min_time_reported
 * /rgbdslam/config/min_translation_meter
 * /rgbdslam/config/neighbor_candidates
 * /rgbdslam/config/nn_distance_ratio
 * /rgbdslam/config/observability_threshold
 * /rgbdslam/config/octomap_online_creation
 * /rgbdslam/config/octomap_resolution
 * /rgbdslam/config/predecessor_candidates
 * /rgbdslam/config/ransac_iterations
 * /rgbdslam/config/store_pointclouds
 * /rgbdslam/config/topic_image_depth
 * /rgbdslam/config/topic_image_mono
 * /rgbdslam/config/topic_points
 * /rgbdslam/config/use_icp
 * /rgbdslam/config/visualization_skip_step
 * /rgbdslam/config/visualize_keyframes_only
 * /rosdistro
 * /rosversion

NODES
  /camera/depth/
    metric (nodelet/nodelet)
    metric_rect (nodelet/nodelet)
    points (nodelet/nodelet)
    rectify_depth (nodelet/nodelet)
  /camera/rgb/
    debayer (nodelet/nodelet)
    rectify_color (nodelet/nodelet)
    rectify_mono (nodelet/nodelet)
  /
    camera_base_link (tf/static_transform_publisher)
    camera_base_link1 (tf/static_transform_publisher)
    camera_base_link2 (tf/static_transform_publisher)
    camera_base_link3 (tf/static_transform_publisher)
    camera_nodelet_manager (nodelet/nodelet)
    rgbdslam (rgbdslam/rgbdslam)
  /camera/
    disparity_depth (nodelet/nodelet)
    disparity_depth_registered (nodelet/nodelet)
    driver (nodelet/nodelet)
    points_xyzrgb_depth_rgb (nodelet/nodelet)
    register_depth_rgb (nodelet/nodelet)
  /camera/ir/
    rectify_ir (nodelet/nodelet)
  /camera/depth_registered/
    metric (nodelet/nodelet)
    metric_rect (nodelet/nodelet)
    rectify_depth (nodelet/nodelet)

WARNING: [/home/jackson/ros/rgbdslam_freiburg/rgbdslam/launch/kinect+rgbdslam.launch] unknown <node> attribute 'no-launch-prefix'
auto-starting new master
process[master]: started with pid [4504]
ROS_MASTER_URI=http://localhost:11311

setting /run_id to 65d80698-bc6b-11e5-a420-000c29347746
process[rosout-1]: started with pid [4517]
started core service [/rosout]
process[camera_nodelet_manager-2]: started with pid [4529]
process[camera/driver-3]: started with pid [4530]
[ INFO] [1452960516.664546337]: Initializing nodelet with 2 worker threads.
process[camera/rgb/debayer-4]: started with pid [4567]
process[camera/rgb/rectify_mono-5]: started with pid [4586]
process[camera/rgb/rectify_color-6]: started with pid [4602]
process[camera/ir/rectify_ir-7]: started with pid [4618]
process[camera/depth/rectify_depth-8]: started with pid [4633]
process[camera/depth/metric_rect-9]: started with pid [4650]
process[camera/depth/metric-10]: started with pid [4666]
process[camera/depth/points-11]: started with pid [4690]
process[camera/register_depth_rgb-12]: started with pid [4706]
process[camera/depth_registered/rectify_depth-13]: started with pid [4732]
process[camera/depth_registered/metric_rect-14]: started with pid [4756]
process[camera/depth_registered/metric-15]: started with pid [4779]
process[camera/points_xyzrgb_depth_rgb-16]: started with pid [4798]
process[camera/disparity_depth-17]: started with pid [4821]
process[camera/disparity_depth_registered-18]: started with pid [4834]
process[camera_base_link-19]: started with pid [4852]
process[camera_base_link1-20]: started with pid [4868]
process[camera_base_link2-21]: started with pid [4882]
process[camera_base_link3-22]: started with pid [4904]
ERROR: cannot launch node of type [rgbdslam/rgbdslam]: can ...
(more)
edit retag flag offensive close merge delete

Comments

Hi!, Which sensor are you using? Is it the new kinect (Kinect for xbox one). I have tried using the new kinect but facing some issues with the usb port. I have been using the usb 3.0 port. But somehow cannot get the data from kinect. Wanted to know your inputs on how you got to run the kinect.

srik11 gravatar imagesrik11 ( 2016-01-17 20:35:17 -0500 )edit

@srik11 I'm using the old kinect for xbox 360 on USB 3. It works with freenect but not with rgbdslam (yet)

jacksonkr_ gravatar imagejacksonkr_ ( 2016-01-18 16:55:57 -0500 )edit

1 Answer

Sort by ยป oldest newest most voted
1

answered 2016-01-16 10:47:29 -0500

goupil35000 gravatar image

Hi,

If you use openni, you can use this one:

roslaunch rgbdslam openni+rgbdslam.launch

Hope this helps

edit flag offensive delete link more

Comments

This works but for some reason my camera isn't connecting..

jacksonkr_ gravatar imagejacksonkr_ ( 2016-01-18 16:55:08 -0500 )edit

This wasn't working on my mac VM (ubuntu 12.04 amd64) but worked on a crappy HP laptop I bought (ubuntu 12.04.05 i386)

jacksonkr_ gravatar imagejacksonkr_ ( 2016-01-28 05:19:29 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2016-01-16 10:13:29 -0500

Seen: 154 times

Last updated: Jan 16 '16