Ask Your Question
0

RVIZ octomap plugin doesn't show produced octomap

asked 2016-01-14 10:17:48 -0500

l4ncelot gravatar image

Hi,

I'm currently trying to produce octomap using octomap_server and my laser range finder in gazebo. Everything seems to work fine, data is published into octoma_server and then published into /octomap_binary topic. Then I'm using rviz octomap plugin to visualize final octomap. Rviz says that everything is ok, but I can't see any visualization of octomap at all...

The funny thing is that yesterday I was able to visualize everything. But then I started to play with newer versions of octomap and tried to override ROS source version of octomap with newer version from git. Then I went through some problems, so I decided to move back to the state when everything worked.

Unfortunately it seems like I forgot on something which is causing me this trouble... Does anybody know where the problem could be? I tried reinstalling whole ros, but this also doesn't do anything...

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
0

answered 2016-01-17 11:51:35 -0500

l4ncelot gravatar image

Ok, so I was able to figure this out... After some reinstalling etc. I displayed occupancy map generated from octomap_server. But this map seemed quite small and not accurate. Then I saw that I didn't change maximum range of my laser sensor in octomap_mapping.launch. After that I was again able to see the map properly...

edit flag offensive delete link more

Comments

Hey! Can you please explain me how you displayed occupancy_map. I have added a question related to this here: https://answers.ros.org/question/2710...

Eyshika gravatar imageEyshika ( 2017-09-16 16:40:09 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

2 followers

Stats

Asked: 2016-01-14 10:17:48 -0500

Seen: 306 times

Last updated: Jan 17 '16