ROS Resources: Documentation | Support | Discussion Forum | Index | Service Status | Q&A answers.ros.org
Ask Your Question
0

roscore: libconsole_bridge.so.0.2: cannot open shared object file

asked 2016-01-14 03:29:38 -0500

Kenavera gravatar image

updated 2016-01-14 06:17:36 -0500

gvdhoorn gravatar image

Hi,

I have ROS (Ros_Comm) installed on my beaglebone black with debian wheezy. While running roscore I get:

/opt/ros/indigo/lib/rosout/rosout: error while loading shared libraries: libconsole_bridge.so.0.2: cannot open shared object file: No such file or directory

While I have libconsole-bridge-dev installed. While installing that I got the message:

-- Installing: /usr/local/lib/arm-linux-gnueabihf/libconsole_bridge.so.0.2.

And nothing failed.

But in the rosout file :

libconsole_bridge.so.0.2 => not found is stated.

Does someone know how I can fix this, I think because libconsole is located at /usr/local/lib.

I tried editting LD_LIBRARY_PATH to /opt/ros/indigo/lib:/opt/ros/indigo/lib/arm-linux-gnueabihf:/usr/local/lib/arm-linux-gnueabihf, but that doesnt seem to help.

And I cant seem to edit the rosout file.

Greetings

Kenavera

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
2

answered 2016-01-14 06:25:19 -0500

Kenavera gravatar image

Well the

LD_LIBRARY_PATH=/opt/ros/indigo/lib:/opt/ros/indigo/lib/arm-linux-gnueabihf:/usr/local/lib/arm-linux-gnueabihf

did fix it. Only the system was durping or, so. Now it works perfectly.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2016-01-14 03:29:38 -0500

Seen: 2,724 times

Last updated: Jan 14 '16