Ask Your Question
0

How to solve Segmentation fault (core dumped) when rviz on raspberry pi 2?

asked 2016-01-07 09:18:56 -0600

YingHua gravatar image

updated 2016-01-07 09:19:48 -0600

As title , how could I solve segmentation fault when rviz?

image description

My raspberry pi 2 img is using ubuntu 14.04 with ros indigo.

I tried to rmove ros-indigo-ros-model and git clone from github to my catkin workspace. ( https://github.com/ros/robot_model )

Here is my steps.

sudo apt-get remove ros-indigo-robot-model 
cd ~/catkin_ws/src 
git clone https://github.com/ros/robot_model.git 
cd ~/catkin_ws
catkin_make 
source devel/setup.bash
rospack profile

But it just works on tegra tk1 not on raspberry pi 2.

Thanks, Alyson

edit retag flag offensive close merge delete

2 Answers

Sort by ยป oldest newest most voted
1

answered 2016-01-07 09:34:35 -0600

updated 2016-01-07 09:36:49 -0600

From http://wiki.ros.org/indigo/Installati...

"Using RVIZ

It is not recommended to run rviz on most ARM-based CPUs. They're generally too slow, and the version of OpenGL that is provided by the software (mesa) libraries it not new enough to start rviz.

'IF' you have a powerful board with a GPU and vendor-supplied OpenGL libraries, it might be possible to run rviz. The IFC6410 and the NVidia Jetson TK1 are two such boards where rviz will run, although neither is fast enough for graphics-heavy tasks such as displaying pointclouds.

Note that rviz will segfault if you have the GTK_IM_MODULE environment variable set, so it's best to unset it in your ~/.bashrc:"

edit flag offensive delete link more

Comments

Do you mean raspberry pi 2 can't use rviz? but github group shows this problem has been solved recently.

http://answers.ros.org/question/22286...

https://github.com/ros/robot_model/is...

YingHua gravatar imageYingHua ( 2016-01-07 10:07:47 -0600 )edit

I just don't know how to do and what are the steps to solve it. :(

YingHua gravatar imageYingHua ( 2016-01-07 10:08:53 -0600 )edit

The page linked to has instruction, missed off copying it
add unset GTK_IM_MODULE to your .bashrc file You may be able to get it to run, but performance is likely to be poor, as detailed in that quote - tegra is much more powerful, especially for graphics with better openGL implementation

nickw gravatar imagenickw ( 2016-01-07 10:38:46 -0600 )edit

I do add unset GTK_IM_MODULE to ~/.bashrc but it doesn't work. https://goo.gl/9EA2X4

YingHua gravatar imageYingHua ( 2016-01-08 02:20:26 -0600 )edit

I would suspect that ubuntu on the pi has less optimisation for the graphics of the board compared with raspbian. You might get rviz to run on that, but i think it will be disappointing performance even if you do get it to launch

nickw gravatar imagenickw ( 2016-01-08 03:08:51 -0600 )edit

YingHua: You found the fixed bug--did you apply one of the two fixes? Either you upgrade libpcre3 or you upgrade collada-dom to the versions containing the fixes. It should fix the segmentation fault right away.

dchang0 gravatar imagedchang0 ( 2016-01-09 00:57:07 -0600 )edit

@dchang0 ok!I will try to upgrade collada-dom. I tried to upgrade libpcre3,it still shows segmentation fault.

YingHua gravatar imageYingHua ( 2016-01-09 23:41:17 -0600 )edit

Upgrading libpcre3 to 8.35 definitely fixed the segmentation fault for me. You should not have to upgrade collada-dom if you did upgrade libpcre3 to high enough a version. It is an "either or" fix.

dchang0 gravatar imagedchang0 ( 2016-01-10 00:11:33 -0600 )edit
0

answered 2016-01-27 07:37:02 -0600

xuminzero gravatar image

I met this question. The reason is that I used the version of ros-indigo-base. When I use the ros-indigo-desktop instead of it, I can use the rviz.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2016-01-07 09:18:56 -0600

Seen: 1,255 times

Last updated: Jan 27 '16