Ask Your Question
0

gmapping on pioneer p3dx robots not able to publish on /map

asked 2015-12-23 08:09:40 -0500

sar1994 gravatar image

updated 2015-12-23 09:46:06 -0500

I am trying to create map using kinect . The following are the commands that i executed :-

$ roscore

$ roslaunch openni_launch openni.launch

$ rosrun depthimage_to_laserscan depthimage_to_laserscan image:=/camera/depth/image_raw

$ rosrun tf static_transform_publisher -0.27 0.0 0.6 0.0 0.0 0.0 base_link camera_link 100

$ rosrun ROSARIA Rosaria _port:=/dev/ttyS0 RosAria/pose:=odom //the above command is for p3dx. It publishes nav_msgs::odom on /RosAria/pose as its /odom

$ rosrun gmapping slam_gmapping scan:=scan

Here gmapping is showing the following warning [ WARN] [1450879595.939251882]: MessageFilter [target=odom ]: Dropped 100.00% of messages so far. Please turn the [ros.gmapping.message_notifier] rosconsole logger to DEBUG for more information.

but when I created a fake odom publisher gmapping worked.

So , help me out to find why is the /odom of rosaria is not able to drive gmapping.

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
0

answered 2016-06-25 00:20:39 -0500

sar1994 gravatar image

There is a synchronisation problem between the robot and the workstation computers. I used chrony for synchronising both and it worked !!

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2015-12-23 08:09:40 -0500

Seen: 401 times

Last updated: Jun 25 '16