Ask Your Question
0

E: Unable to correct problems, you have held broken packages. How should I solve this ? [closed]

asked 2015-12-16 11:47:12 -0500

Neel gravatar image

This error occurred when I was trying to run 'rosdep install rviz'. Could you please help me to solve this ?

I have installed 'indigo'.

edit retag flag offensive reopen merge delete

Closed for the following reason question is not relevant or outdated by 130s
close date 2017-03-07 16:28:53.233142

2 Answers

Sort by ยป oldest newest most voted
1

answered 2015-12-16 16:11:34 -0500

ahendrix gravatar image

Your Ubuntu package manager (apt) has gotten into a bad state, and can't do anything until you fix it. This can happen if the package install process is interrupted or encounters an error.

You can try apt-get install -f to see if apt can recover; otherwise you'll need to figure out which packages are stuck or broken and debug the issue.

This isn't really related to ROS; you'll probably be able to find better help elsewhere.

edit flag offensive delete link more
1

answered 2015-12-16 17:03:02 -0500

demmeln gravatar image

Maybe it is related to this issue with Ubuntu 14.04.2 / 14.04.3: http://answers.ros.org/question/20361...

edit flag offensive delete link more

Question Tools

Stats

Asked: 2015-12-16 11:47:12 -0500

Seen: 3,388 times

Last updated: Dec 16 '15