ROS Resources: Documentation | Support | Discussion Forum | Index | Service Status | Q&A answers.ros.org
Ask Your Question
0

ros-foxy installation issue

asked 2022-03-04 01:32:17 -0500

rukey3001 gravatar image

updated 2022-03-05 14:08:54 -0500

osilva gravatar image

When I tried to reinstall ros-foxy I'm getting this error. Pls help.

$ sudo apt install ros-foxy-desktop


Reading package lists... Done
Building dependency tree       
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 ros-foxy-desktop : Depends: ros-foxy-joy but it is not going to be installed
                    Depends: ros-foxy-teleop-twist-joy but it is not going to be installed
E: Unable to correct problems, you have held broken packages.
edit retag flag offensive close merge delete

2 Answers

Sort by ยป oldest newest most voted
0

answered 2022-03-05 14:45:26 -0500

aarsh_t gravatar image

Yes I had similar issue while recent installation, It is due to some version mismatch. I tried to downgrading few dependencies but it didn't worked well and I lost few drivers and software. I was using Ubuntu 20.04.4 but then I shifted to the Ubuntu 20.04.2 it was solved. I am not sure if you are considering the downgrading the system or not but it can be one of the solution.

edit flag offensive delete link more
0

answered 2022-03-05 14:15:42 -0500

osilva gravatar image

Hi @rukey3001

Please take a look at prior answer: #q279780 as it offers a couple approaches how to find the problematic dependencies.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2022-03-04 01:32:17 -0500

Seen: 270 times

Last updated: Mar 05