Ask Your Question
0

Robot on same network (Ubuntu/Fedora)

asked 2015-12-16 04:40:10 -0500

Maya gravatar image

updated 2015-12-16 04:49:57 -0500

Hey all,

I'm using a robot with a ubuntu 14,04 and ros indigo and my own computer with Fedora 23 and a source install of ros indigo. I'm trying to connect them using the wifi network generated by my robot.

I fixed the env variable for both platform. On my computer with a fixed IP of 10.0.0.115 :

ROS_MASTER_URI=http://10.0.0.3:11311
ROS_HOSTNAME=10.0.0.115
ROS_IP=10.0.0.115

On the robot, I did :

robot@ROBOT:~$ export ROS_MASTER_URI=http://10.0.0.3:11311
robot@ROBOT:~$ export ROS_IP=10.0.0.3
robot@ROBOT:~$ export ROS_HOSTNAME=10.0.0.3

After this. if I launch the roscore on the robot, I can listen to everything that is publish from the robot on my computer but everything that is publish from my computer to the robot is lost.

If I run roswtf on my computer it doesn't return any errors while, on the robot, roswtf return this :

Found 2 error(s).

ERROR Could not contact the following nodes:
 * /rostopic_8305_1450259505852

ERROR Errors connecting to the following services:
 * service [/rostopic_8305_1450259505852/set_logger_level] appears to be malfunctioning: Unable to communicate with service [/rostopic_8305_1450259505852/set_logger_level], address [rosrpc://10.0.0.115:42198]
 * service [/rostopic_8305_1450259505852/get_loggers] appears to be malfunctioning: Unable to communicate with service [/rostopic_8305_1450259505852/get_loggers], address [rosrpc://10.0.0.115:42198]

I tried the same step I used on my fedora on a Ubuntu computer and the publishing from the computer worked fine. I did very step that is on this page and they all worked apart from the netcat one. I can write from my computer to the robot alright but is I open a port o my computer using nc -l 1234 and try to write to it on the robot with netcat 10.0.0.115 1234 then the command return without doing anything :

robot@ROBOT netcat 10.0.0.115 1234
robot@ROBOT:~$

It seems that the robot cannot connect the topic published from my computer and I'm at a loss as to why. Any help is appreciated :)

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
0

answered 2015-12-16 05:43:49 -0500

Maya gravatar image

Found the solution, the ssh server needs to be running on fedora :

service sshd start
edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2015-12-16 04:40:10 -0500

Seen: 103 times

Last updated: Dec 16 '15