Ask Your Question
0

XV11 Producing poor maps with gmaping

asked 2015-11-07 15:55:54 -0500

ChrisL8 gravatar image

I purchased an XV11 Neato "Lidar" from "GetSurreal", this one specifically: http://www.getsurreal.com/product/xv-... a few months ago.

However I was unable to create a usable map using ROS Gmapping. I can navigate an existing map made with the ASUS Xtion, but trying to use the XV11 Lidar to create a map in ROS was impossible.

Reading through the posts it sounds like some people here are using the XV11 Lidar with ROS Gmapping.

Rather than try to explain the issue, I will include a picture Can anyone point me to what I might be doing wrong that is causing this?

Here is what a map of the room using the ASUS 3D camear looks like: image description

Here is what the XV11 produces: image description

Notice how the ASUS makes neat clean walls, while the XV11 produces odd dotted lines that eventually spread apart.

Note that both are mounted on the robot, so odometry and everything else is exactly the same. The only difference is their height.

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
1

answered 2015-11-09 19:37:28 -0500

jseal gravatar image

updated 2015-11-09 21:13:58 -0500

Look into the variable minimumScore. see this post it goes into a lot more detail.

It even show some other gmapping options that works good with the xv11 laser.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

3 followers

Stats

Asked: 2015-11-07 15:55:54 -0500

Seen: 369 times

Last updated: Nov 09 '15