Ask Your Question
0

How to make the robot follows exactly the global plan?

asked 2015-10-29 10:00:10 -0500

Ahmed gravatar image

I need to make my robot to follow the path planned by the global planner and completely ignore the local planner.

edit retag flag offensive close merge delete

2 Answers

Sort by ยป oldest newest most voted
3

answered 2015-10-30 00:57:03 -0500

Akif gravatar image

You can increase pdist_scale parameter value. It is distance-to-path scoring weight. Its default value is 0.6. You may try values like 0.8, or 0.9 . For the wiki: http://wiki.ros.org/base_local_planner

edit flag offensive delete link more
0

answered 2015-10-30 13:15:54 -0500

l0g1x gravatar image

You can look into using the pose_follower package which does exactly what your asking for. It is however long outdated on the ROS Wiki page for that package, so i recommend that you look into this repo as those guys have been adding to the pose_follower package and it worked on indigo for me.

You will need to change your navigation parameters to load pose_follower as a local planner as opposed to base_local_planner

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2015-10-29 10:00:10 -0500

Seen: 694 times

Last updated: Oct 30 '15