Turtlebotv1 Calibration error

asked 2015-10-28 21:58:42 -0600

nicobari gravatar image

updated 2015-10-28 21:59:28 -0600

Hi, I assembled a Turtlebotv1 on Create and using kinect as a 3D sensor, Also I am running ROS Indigo on Xubuntu 14.04. I also got Powersensor board manufactures and using ADXRS613 gyro. I am trying to calibrate the Turtlebot and run

roslaunch turtlebot_calibration calibrate.launch

First of all I have to keep pretty far from the wall like around half a meter for it to even start calibration. Also I am getting following warnings

[ WARN] [1446086529.511185488]: Could not find any compatible depth output mode for 1. Falling back to default depth output mode 1.
[ INFO] [1446086529.534847605]: rgb_frame_id = 'camera_rgb_optical_frame' 
[ INFO] [1446086529.534952916]: depth_frame_id = 'camera_depth_optical_frame' 
[ WARN] [1446086529.559807771]: Camera calibration file /home/wvuirl/.ros/camera_info/rgb_A70777V01125309A.yaml not found.
[ WARN] [1446086529.559959598]: Using default parameters for RGB camera calibration.
[ WARN] [1446086529.560042763]: Camera calibration file /home/wvuirl/.ros/camera_info/depth_A70777V01125309A.yaml not found.
[ WARN] [1446086529.560110529]: Using default parameters for IR camera calibration.

Then I get following output

[INFO] [WallTime: 1446086323.993649] Still waiting for scan
[INFO] [WallTime: 1446086324.294945] Still waiting for scan
[INFO] [WallTime: 1446086324.595806] Still waiting for scan
[INFO] [WallTime: 1446086324.896803] Still waiting for scan
[INFO] [WallTime: 1446086325.197429] Still waiting for scan
[INFO] [WallTime: 1446086325.498272] Still waiting for scan
[ INFO] [1446086326.523293856]: Stopping device RGB and Depth stream flush.
[INFO] [WallTime: 1446086336.109565] Still waiting for imu
[INFO] [WallTime: 1446086336.411070]  ... imu drift is -0.207569 degrees per second
[INFO] [WallTime: 1446086336.712768] Still waiting for imu
[INFO] [WallTime: 1446086337.013728] Aligning base with wall
[INFO] [WallTime: 1446086337.315038] Still waiting for imu
[ERROR] [WallTime: 1446086370.909854] Please point me at a wall.
[ERROR] [WallTime: 1446086370.945926] Please point me at a wall.
[ERROR] [WallTime: 1446086370.985890] Please point me at a wall.
[ERROR] [WallTime: 1446086371.025919] Please point me at a wall.
[ERROR] [WallTime: 1446086371.065689] Please point me at a wall.
[ERROR] [WallTime: 1446086371.105884] Please point me at a wall.

It does start to rotate but never stops and then starts outputting "Please point me at a wall". I can see the kinect is turned on as I see a red light in one of the lenses. I have checked the forum and my calibrate.launch file is already modified as discussed in http://answers.ros.org/question/54279... and http://answers.ros.org/question/64301... . I have also tried roslaunch turtlebot_bringup 3dsensor.launch it works but I get the same calibration and depth setting warning and I can see the image when I run roslaunch turtlebot_rviz_launchers view_robot.launch. So I am completely clueless regarding what is going on and how I can fix it. I will really appreciate any help regarding this matter.

Thanks, TM

edit retag flag offensive close merge delete