ROS-Indigo-Turtlebot Android-teleop not working

asked 2017-08-14 20:20:29 -0600

Red24Dog gravatar image

updated 2017-08-15 02:09:22 -0600

gvdhoorn gravatar image

With fresh (August 2017) Ubuntu 14.04 (Trusty), ROS-Indigo-turtlebot (kinect-create) installation on a netbook pc, usual functions keyboard & ps3 joy teleop, RVIZ and image_view (image_raw and registered image) works with clean minimal, 3dsensor.launch. However, installing a fresh Android (4.0.4 Icecream Sandwich) Teleop (Indigo Ver. 1.0.0) "connects" but does not drive turtlebot nor show image or battery status. The app appears active with the expected virtual joystick indication on the Android screen and it does not crash.

The turtlebot ~$ rosnode list shows /android/camera_view and /android/virtual_joystick , so the android appears to be properly connected into the turtlebot system.

Investigating further with rosnode info shows the appropraite node details, below, but rosrun rqt_graph rqt_graph, while showing the android box and nodes, show NO connecting links to any other nodes. rostopic echo /cmd_vel show changing liner and angular values, as expected.

Another curious observation is that the /android/camera_view Node Subscribes to /compressed_image [unknown type] which does not exist in the rosnode list display. The closest Node name might be /camera/rgb/image_color/compressed ? Does the android rosjava app need to be revised?

Is there an additional command to launch or run or a parameter to set to 'enable" or launch the android function? There is no text in the minimal.launch screen log referring to android, info, warning or error.

~$ rosnode info /android/virtual_joystick
--------------------------------------------------------------------------------
Node [/android/virtual_joystick]
Publications: 
 * /cmd_vel [geometry_msgs/Twist]
 * /rosout [rosgraph_msgs/Log]

Subscriptions: 
 * /odom [nav_msgs/Odometry]

Services: None

contacting node http://192.168.2.122:53246/ ...
Pid: 13755
Connections:
 * topic: /rosout
    * to: /rosout
    * direction: outbound
    * transport: TCPROS

turtlebot@herschel:~$ rosnode info /android/camera_view
--------------------------------------------------------------------------------
Node [/android/camera_view]
Publications: 
 * /rosout [rosgraph_msgs/Log]

Subscriptions: 
 * /compressed_image [unknown type]

Services: None


contacting node http://192.168.2.122:37602/ ...
Pid: 13755
Connections:
 * topic: /rosout
    * to: /rosout
    * direction: outbound
    * transport: TCPROS

turtlebot@herschel:~$ rostopic echo /cmd_vel
linear: 
  x: -0.20135678895
  y: -0.0
  z: 0.0
angular: 
  x: 0.0
  y: 0.0
  z: 0.0423908977128
---
linear: 
  x: -0.171266657133
  y: -0.0
  z: 0.0
angular: 
  x: 0.0
  y: 0.0
  z: 0.065484302429

Any suggested investigation steps would be appreciated.

edit retag flag offensive close merge delete