Ask Your Question
0

qtcreator debug ROS

asked 2015-10-24 15:33:58 -0600

goupil35000 gravatar image

Hi,

I tried to run a ros node in qtcreator (version 3.5.1). It works in debug mode, I can have breakpoints, see variables ... I was able to change option for CMAKE ... with option Debug. No problem I think here;

But I don't see where are the outputs (I have ROS_INFO lines in my ros file). I can see that it works when I do a "rostopic echo /rosout_agg" in another terminal. But it's difficult to see my debug messages with others messages which come in.

So my question is simple: where can I see the messages when I execute lines with ROS_INFO.

Thanks for help

qtcreator 3.5.1, ubuntu 14.04.3, ROS indigo

edit retag flag offensive close merge delete

3 Answers

Sort by ยป oldest newest most voted
0

answered 2015-10-25 03:56:10 -0600

If you start your node from inside QtCreator (as opposed to attaching to a node you started externally), you should be able to see it's output in the "3 Application Output" Tab as visible on the bottom in this Screenshot from Wikipedia.

edit flag offensive delete link more
0

answered 2015-10-25 04:28:21 -0600

goupil35000 gravatar image

Hi, Thanks Stefan. But In Application Output I only have "Debugging starts" and "Debugging has finished". No output from ROS_INFO.

So the question is still there.

edit flag offensive delete link more
0

answered 2015-10-26 03:14:52 -0600

mrslvgg gravatar image

In Debug mode you should be able to see your info messages in Qt Application Output. I attached an image of my project in which you can see the output of a ROS_INFO line.

image description

Hope this helps.

edit flag offensive delete link more

Comments

Hi Mario, Thanks but I don't have the same as you. I tried with part of your code, and it's the same. In Application Output, I get "Debugging starts" and after ... nothing. Except Debugging has finished when I stop the code (I publish in a topic every second). Is-it a bug ? Thanks.

goupil35000 gravatar imagegoupil35000 ( 2015-10-26 15:39:22 -0600 )edit

I suggest few things: - make sure you start qt creator from terminal, after sourced your environment - make sure to uncheck the "run in terminal" checkbox in "project->run settings" - check cmake argument -DCMAKE_BUILD_TYPE=Debug - try to remove CMakeLists.txt.user in your catkin_ws and restart qt.

mrslvgg gravatar imagemrslvgg ( 2015-10-26 15:56:26 -0600 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2015-10-24 15:33:58 -0600

Seen: 929 times

Last updated: Oct 26 '15