messages not being generated on (arm-hf?) [closed]

asked 2015-10-09 06:05:58 -0500

drewm1980 gravatar image

For some reason after a recent ROS update, catkin is no longer generating messages when I build on an odroid/arm device. Message generation worked before the update and still works with the same code on x86-64.

Both machines are running Ubuntu 14.04 cmake 3.3.20150814-g17ecf ros-indigo g++ 5.1

I am using catkin_make. On the x86-64 laptop I get the blue lines "Generating C++ code from ..." but I don't see them (anymore) on the odroid machine. The build breaks on a #include of the non-generated header files.

Any ideas? Is there another way I can trigger message file generation outside of catkin?

edit retag flag offensive reopen merge delete

Closed for the following reason question is not relevant or outdated by drewm1980
close date 2015-10-13 15:28:33.256296


Maybe it is a parallelism problem, have you tried building a second time or with -j1?

William gravatar image William  ( 2015-10-09 10:57:48 -0500 )edit

Yeah, I think it is an undeclared dependency in the build configuration causing a compile-time race that only shows up on slower machines... building a bunch of times eventually "worked".

drewm1980 gravatar image drewm1980  ( 2015-10-13 15:26:44 -0500 )edit