roslaunch is unable to find package i want to launch, and it does not show up in ROS paths listed during launch. When I echo my ROS_PACKAGE_PATH, however, it is definitely there. How can I fix this?

asked 2015-10-01 10:38:52 -0600

bdrober3 gravatar image

Warning: relatively new ROS and linux user. I am having trouble getting a package to launch on a remote computer. The package I am trying to launch is in the folder /home/spencelab/catkin_ws/src. If I enter

$echo $ROS_PACKAGE_PATH

returns

/home/spencelab/catkin_ws/src:/opt/ros/indigo/share:/opt/ros/indigo/stacks

however, when I use roslaunch, it returns the following error:

[Mocap-Computer-1-0]: ERROR: cannot launch node of type [cambuffer_recorder/cambuffer_recorder_node]: cambuffer_recorder
ROS path [0]=/opt/ros/indigo/share/ros
ROS path [1]=/opt/ros/indigo/share
ROS path [2]=/opt/ros/indigo/stacks

I am ~95% sure my .launch file is correctly formatted for launching the cambuffer_recorder package. Why is the directory I want to launch my package from not showing up on the list of ROS paths? How can I append this list?

Right now I am setting the ROS_PACKAGE_PATH variable in my .bashrc file by appending the line:

export ROS_PACKAGE_PATH=/home/spencelab/catkin_ws/src:$ROS_PACKAGE_PATH

I am also trying to set a few other things from my .bashrc file as well. The full list of appended features looks like this:

export ROS_MASTER_URI=http://nyewhy:11311
export ROS_PACKAGE_PATH=/home/spencelab/catkin_ws/src:$ROS_PACKAGE_PATH
source /opt/ros/indigo/setup.bash
source /home/spencelab/catkin_ws/devel/setup.bash

Is there something conflicting in my .bashrc file? Can anyone think of a good reason why I can successfully set ROS_MASTER_URI, but not ROS_PACKAGE_PATH in this manor? Any help is greatly appreciated!

edit retag flag offensive close merge delete

Comments

How are you trying to run things 'on a remote computer'. Is this after logging in using SSH? If so, your .bashrc is not (normally) read then. You'll need to setup things differently. See roslaunch/XML/machine for how to do this with launch files.

gvdhoorn gravatar image gvdhoorn  ( 2015-10-01 13:56:41 -0600 )edit

I don't have to manually set ROS_PACKAGE_PATH in my .bashrc if I setup the catkin workspace correctly.

jeremya gravatar image jeremya  ( 2015-10-02 14:39:14 -0600 )edit