Ask Your Question
0

Hey guys, I installed ROS jade instead of ROS indigo and I keep getting the following error while installing the rosdep. Someone knows what to do?

asked 2015-08-26 22:41:10 -0600

martin94 gravatar image

updated 2015-08-27 10:25:17 -0600

gvdhoorn gravatar image
martin94@ubuntu:~$ sudo rosdep init
ERROR: default sources list file already exists:
    /etc/ros/rosdep/sources.list.d/20-default.list
Please delete if you wish to re-initialize

martin94@ubuntu:~$ rosdep update
reading in sources list data from /etc/ros/rosdep/sources.list.d
Hit https://raw.githubusercontent.com/ros/rosdistro/master/rosdep/osx-homebrew.yaml
Hit https://raw.githubusercontent.com/ros/rosdistro/master/rosdep/base.yaml
Hit https://raw.githubusercontent.com/ros/rosdistro/master/rosdep/python.yaml
Hit https://raw.githubusercontent.com/ros/rosdistro/master/rosdep/ruby.yaml
Hit https://raw.githubusercontent.com/ros/rosdistro/master/releases/fuerte.yaml
Query rosdistro index https://raw.githubusercontent.com/ros/rosdistro/master/index.yaml
Add distro "groovy"
Add distro "hydro"
Add distro "indigo"
Add distro "jade"
updated cache in /home/martin94/.ros/rosdep/sources.cache

martin94@ubuntu:~$ echo "source /opt/ros/indigo/setup.bash" >> ~/.bashrc
martin94@ubuntu:~$ echo "source /opt/ros/indigo/setup.bash" >> ~/.bashrc
martin94@ubuntu:~$ source ~/.bashrc
bash: /opt/ros/jade/setup.bash: No such file or directory
bash: /opt/ros/jade/setup.bash: No such file or directory

output of ls -al /opt/ros:

martin94@ubuntu:~$ ls -al /opt/ros
total 12
drwxr-xr-x 3 root root 4096 Aug 26 20:06 .
drwxr-xr-x 3 root root 4096 Aug 26 20:06 ..
drwxr-xr-x 7 root root 4096 Aug 26 20:06 indigo
edit retag flag offensive close merge delete

2 Answers

Sort by ยป oldest newest most voted
1

answered 2015-08-27 10:20:59 -0600

updated 2015-08-27 10:33:07 -0600

you need to edit your .bashrc file and remove the line that is trying to source the jade script - it looks like you do have indigo installed as you, but looks like you have also have added that line to your .bashrc file

In terminal in your home folder gedit .bashrc will open it, scroll down to the bottom and remove the line that sources the jade file, leave in the one for indigo. Save changes

edit flag offensive delete link more

Comments

It worked thanks!

martin94 gravatar imagemartin94 ( 2015-08-27 11:08:18 -0600 )edit

thats great - please accept either of these answers as correct (click on the tick) to tidy up the forum

nickw gravatar imagenickw ( 2015-08-28 12:07:39 -0600 )edit
1

answered 2015-08-27 01:44:04 -0600

gvdhoorn gravatar image

updated 2015-08-27 10:30:05 -0600

martin94@ubuntu:~$ sudo rosdep init
ERROR: default sources list file already exists:
    /etc/ros/rosdep/sources.list.d/20-default.list
Please delete if you wish to re-initialize

This you can ignore (unless you want to re-initialize): you only need to run sudo rosdep init once, even if you (re)install a different version of ROS.

martin94@ubuntu:~$ echo "source /opt/ros/indigo/setup.bash" >> ~/.bashrc
martin94@ubuntu:~$ echo "source /opt/ros/indigo/setup.bash" >> ~/.bashrc

If this is an actualy copy/paste, then again: you only need to do this once. The >> will cause bash to append the line you give to echo to the .bashrc file, so you'll now have multiple. That is not really an issue, just unnecessary.

martin94@ubuntu:~$ source ~/.bashrc
bash: /opt/ros/jade/setup.bash: No such file or directory

Are you sure you have installed ROS Jade on this machine? This basically tells you that bash was unable to find setup.bash in the /opt/ros/jade directory. A successful installation of ROS Jade should have placed that file there.

Can you add the output of ls -al /opt/ros to your original question? Please use the edit button / link for that.

Also: please add on which OS you are doing this (ubuntu, yes, but which version?).


Edit: seems you edited your question title (old title: "Hey guys, I installed ROS jade instead of ROS indigo and I keep getting the following error while installing the rosdep. Someone knows what to do?"). My previous answer assumed you had Jade installed, not Indigo.

output of ls -al /opt/ros:

martin94@ubuntu:~$ ls -al /opt/ros
[..]
drwxr-xr-x 7 root root 4096 Aug 26 20:06 indigo

From this (and from your updated question title), it seems you only have Indigo installed, but your .bashrc is still trying to read the setup.bash file under /opt/ros/jade. You don't have that, hence the error (the No such file or directory error, not the rosdep error, that is unrelated).

Open .bashrc, and look for a line source /opt/ros/jade/.. at the end of it. Remove any lines that have source and jade in them.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2015-08-26 22:41:10 -0600

Seen: 1,714 times

Last updated: Aug 27 '15