Ask Your Question
0

Couldn't find executable named tf_brodcaster below

asked 2015-08-24 04:11:19 -0600

Greyshades gravatar image

updated 2015-08-24 04:57:47 -0600

gvdhoorn gravatar image

Hi all,

I am new to ROS

My question is similar to a previous question asked.

I am following the tutorial http://wiki.ros.org/navigation/Tutori...

And I am stuck with the robot_setup_tf part. Whereby I run the command

rosrun robot_setup_tf tf_broadcaster

Initially I get

package robot_setup_tf not found

I have tried the sourcing the setup.bash file in my catkin_ws/devel, (From the 1st link)

source /path/to/your/catkin_ws/devel/setup.bash

It solves the previous error, however, now I get a new error

Couldn't find executable named tf_brodcaster below /home/user1/catkin_ws/src/robot_setup_tf

I am running on ROS indigo. Would appreciate assistance!

Thanks alot in advance!

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
0

answered 2015-08-24 04:28:43 -0600

gvdhoorn gravatar image
"Couldn't find executable named tf_brodcaster below [..]"

Is this an actual copy/paste? Because there is a typo there: it's tf_broadcaster, not tf_brodcaster (note the missing a).

edit flag offensive delete link more

Comments

Apologies for the typo. Yes it worked after I fixed the typo! Thanks for spotting it! Thanks again for your help!

Greyshades gravatar imageGreyshades ( 2015-08-24 04:56:18 -0600 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2015-08-24 04:11:19 -0600

Seen: 298 times

Last updated: Aug 24 '15