error in rosrun rosserial_python window

asked 2015-08-20 05:38:29 -0600

Emilio gravatar image

Hi all!

When i run rosrun rosserial_pyton /dev/ttyACM0 in a terminal it works well, but when i run rostopic pub in other terminal window i get the following error:

emilio@emilio-N61Vg:~/catkin_ws$ rosrun rosserial_python /dev/ttyACM0

[INFO] [WallTime: 1440066369.914559] ROS Serial Python Node

[INFO] [WallTime: 1440066369.920107] Connecting to /dev/ttyACM0 at 57600 baud

[INFO] [WallTime: 1440066372.763812] Note: publish buffer size is 280 bytes

[INFO] [WallTime: 1440066372.764439] Setup publisher on angulo [geometry_msgs/Vector3]

[INFO] [WallTime: 1440066372.769408] Note: subscribe buffer size is 280 bytes

[INFO] [WallTime: 1440066372.769842] Setup subscriber on posicion [geometry_msgs/Point]

[INFO] [WallTime: 1440066372.774876] Setup subscriber on modo [geometry_msgs/Vector3]

[WARN] [WallTime: 1440066399.909818] Serial Port read returned short (expected 24 bytes, received 0 instead).

[WARN] [WallTime: 1440066399.910426] Serial Port read failure:

[INFO] [WallTime: 1440066399.911157] Packet Failed : Failed to read msg data

[INFO] [WallTime: 1440066399.911781] msg len is 24

[INFO] [WallTime: 1440066399.947560] Setup publisher on angulo [geometry_msgs/Vector3]

[WARN] [WallTime: 1440066404.668613] Serial Port read returned short (expected 24 bytes, received 21 instead).

[WARN] [WallTime: 1440066404.669382] Serial Port read failure:

[INFO] [WallTime: 1440066404.670133] Packet Failed : Failed to read msg data

[INFO] [WallTime: 1440066404.670843] msg len is 24

Traceback (most recent call last):

File "/opt/ros/indigo/lib/rosserial_python/", line 82, in <module>

File "/opt/ros/indigo/lib/python2.7/dist-packages/rosserial_python/", line 495, in run self.requestTopics()

File "/opt/ros/indigo/lib/python2.7/dist-packages/rosserial_python/", line 392, in requestTopics self.port.flushInput()

File "/usr/lib/python2.7/dist-packages/serial/", line 500, in flushInput termios.tcflush(self.fd, TERMIOS.TCIFLUSH)

termios.error: (5, 'Input/output error')


Thanks if anyone know what is the problem.

edit retag flag offensive close merge delete


Hello. Please give to me answer...Did you find a solution?

Tvlad gravatar image Tvlad  ( 2016-06-30 08:14:54 -0600 )edit