Ask Your Question
0

roscd: No such package/stack 'turtlebot_navigation/'

asked 2015-08-19 09:58:14 -0500

DENSO gravatar image

After following the tutorial in this link click here and go all the way down to ( Running the Plugin on the Turtlebot )

when i run this command $ roscd turtlebot_navigation/ i get in error say roscd: No such package/stack 'turtlebot_navigation/'

also when i run the other command $ cd launch/includes/ i get in error say bash: cd: launch/includes/: No such file or directory

In addition, Do i have to have the turtlebot robot to run the navigation

i really appreciate your help and time

edit retag flag offensive close merge delete

2 Answers

Sort by ยป oldest newest most voted
1

answered 2015-08-19 13:23:46 -0500

staljbs gravatar image

Please check if the turtlebot pkgs have been released for Jade? I think the latest officially supported release is for indigo. Check this link: http://wiki.ros.org/Robots/TurtleBot

edit flag offensive delete link more

Comments

Thank you for your help, can you please answer this question CLICK HERE

DENSO gravatar image DENSO  ( 2015-08-19 13:46:49 -0500 )edit
1

answered 2015-08-19 10:12:08 -0500

updated 2015-08-19 10:14:03 -0500

Well roscd: No such package/stack 'turtlebot_navigation/' means the package

turtlebot_navigation

is not installed.

You should be able to install it with sudo apt-get install ros-indigo-turtlebot-navigation

The second error is a following error, because it expects your directory to be the one of turtlebot_navigation now, but it could not be found... so you stay in the former directory and there is no subdirectory called launch.

edit flag offensive delete link more

Comments

after following your instucrtion i get in error say

 E: Unable to locate package ros-jade-turtlebot-navigation

and my ROS version is jade

DENSO gravatar image DENSO  ( 2015-08-19 10:24:23 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2015-08-19 09:58:14 -0500

Seen: 1,523 times

Last updated: Aug 19 '15