Ask Your Question
0

ROS in Arch linux

asked 2015-08-10 14:45:13 -0600

AbdealiJK gravatar image

updated 2015-08-10 14:49:08 -0600

I'm trying to install ROS in Arch - and I was able to get https://aur4.archlinux.org/packages/r... installed.

After that I used the following in my bashrc and run rosenv before running ros commands: rosenv2 () { source /opt/ros/indigo/setup.bash export PYTHONPATH=/opt/ros/indigo/lib/python2.7/site-packages:$PYTHONPATH

  export ROS_PACKAGE_PATH=/opt/OGRE-1.8/lib/pkgconfig:/opt/ros/indigo/lib/pkgconfig:$ROS_PACKAGE_PATH

  export LD_LIBRARY_PATH=/opt/OGRE-1.8/lib:$LD_LIBRARY_PATH
  export CMAKE_MODULE_PATH=/opt/OGRE-1.8/lib/OGRE:$CMAKE_MODULE_PATH

  # Useful aliases
  alias catkin_make="catkin_make -DPYTHON_EXECUTABLE=/usr/bin/python2 -DPYTHON_INCLUDE_DIR=/usr/include/python2.7 -DPYTHON_LIBRARY=/usr/lib/libpython2.7.so"

  # If you use Gazebo:
  #source /usr/share/gazebo/setup.sh
}

When I do catkin_make in one of my workspaces - I get the following error:

CMake Error at /usr/lib64/cmake/gazebo/gazebo-config.cmake:46 (find_package):
  By not providing "FindOGRE.cmake" in CMAKE_MODULE_PATH this project has
  asked CMake to find a package configuration file provided by "OGRE", but
  CMake did not find one.

  Could not find a package configuration file provided by "OGRE" with any of
  the following names:

    OGREConfig.cmake
    ogre-config.cmake

  Add the installation prefix of "OGRE" to CMAKE_PREFIX_PATH or set
  "OGRE_DIR" to a directory containing one of the above files.  If "OGRE"
  provides a separate development package or SDK, be sure it has been
  installed.
Call Stack (most recent call first):
  gazebo_ros_pkgs/gazebo_ros/CMakeLists.txt:26 (find_package)


-- Configuring incomplete, errors occurred!

I've installed https://aur4.archlinux.org/packages/o... also (as suggested on the wiki page in ROS+Arch)

Any help on how to fix this ?

edit retag flag offensive close merge delete

Comments

You have source /usr/share/gazebo/setup.sh commented out in your rosenv2() function. The gazebo-config.cmake script might need something from the gazebo setup.sh....

hauptmech gravatar imagehauptmech ( 2015-12-01 16:05:48 -0600 )edit

1 Answer

Sort by ยป oldest newest most voted
0

answered 2015-08-27 01:30:32 -0600

bchr gravatar image

updated 2015-08-27 01:31:18 -0600

You should no longer need Ogre 1.8. It was required a while ago when RViz and Gazebo were not compatible with Ogre 1.9, but this is no longer the case. Which Wiki are you referring to? No such thing is written in the ROS wiki. If you also used Ogre 1.8 when compiling desktop_full, try to reinstall the packages that require Ogre directly or indirectly, then try again.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

Stats

Asked: 2015-08-10 14:45:13 -0600

Seen: 698 times

Last updated: Aug 27 '15