moveit pr2 self filter with tilt laser

asked 2015-07-30 21:30:52 -0600

evan gravatar image

updated 2015-07-30 21:48:25 -0600

I'm trying to use the pr2's tilt laser with moveit and am unable to get self-filtering to work properly. I have verified that using the head mount kinect works. To get the tilt laser working I made a new sensors_laser.yaml file and also modified the move_group.launch file to use the sensors_laser.yaml instead of the default sensors_kinect.yaml. Using rviz I have verified that the planning scene is using the /tilt_scan_cloud, and have also verified that the self-filtered output cloud (tilt_scan_self_filtered_cloud) has not actually filtered out the robot.

Here is the sensors_laser.yaml file that I'm using.

  - sensor_plugin: occupancy_map_monitor/PointCloudOctomapUpdater
    point_cloud_topic: /tilt_scan_cloud
    max_range: 10.0
    shape_padding: 0.05
    shape_scale: 1.0
    frame_subsample: 1
    point_subsample: 1
    filtered_cloud_topic: tilt_scan_self_filtered_cloud

Am I missing params or do I need to make other changes somewhere? Any suggestions would be great. Thanks for your help.

edit retag flag offensive close merge delete