Ask Your Question
1

Failed to process package 'compressed_depth_image_transport'

asked 2015-07-24 17:16:32 -0600

zoe gravatar image

updated 2015-07-25 02:07:50 -0600

gvdhoorn gravatar image

Hi I'm trying to install ROS Indigo on OS X Yosemite, and executing

$ ./src/catkin/bin/catkin_make_isolated --install -DCMAKE_BUILD_TYPE=Release

I have come across the following error. How can I resolve it?

==> Processing catkin package: 'compressed_depth_image_transport'
==> Building with env: '/Users/Zoe/ros_catkin_ws/install_isolated/env.sh'
Makefile exists, skipping explicit cmake invocation...
==> make cmake_check_build_system in '/Users/Zoe/ros_catkin_ws/build_isolated/compressed_depth_image_transport'
==> make -j4 -l4 in '/Users/Zoe/ros_catkin_ws/build_isolated/compressed_depth_image_transport'
[ 25%] Built target compressed_depth_image_transport_gencfg
Linking CXX shared library /Users/Zoe/ros_catkin_ws/devel_isolated/compressed_depth_image_transport/lib/libcompressed_depth_image_transport.dylib
ld: library not found for -ltbb
clang: error: linker command failed with exit code 1 (use -v to see invocation)
make[2]: *** [/Users/Zoe/ros_catkin_ws/devel_isolated/compressed_depth_image_transport/lib/libcompressed_depth_image_transport.dylib] Error 1
make[1]: *** [CMakeFiles/compressed_depth_image_transport.dir/all] Error 2
make: *** [all] Error 2
<== Failed to process package 'compressed_depth_image_transport': 
  Command '['/Users/Zoe/ros_catkin_ws/install_isolated/env.sh', 'make', '-j4', '-l4']' returned non-zero exit status 2

Reproduce this error by running:
==> cd /Users/Zoe/ros_catkin_ws/build_isolated/compressed_depth_image_transport && /Users/Zoe/ros_catkin_ws/install_isolated/env.sh make -j4 -l4
edit retag flag offensive close merge delete

Comments

I'm currently having the same issue on El Capitan.

alf gravatar imagealf ( 2015-10-15 03:11:16 -0600 )edit

1 Answer

Sort by ยป oldest newest most voted
0

answered 2015-07-27 03:07:48 -0600

William gravatar image

Looks like you're missing tbb, did you run rosdep to make sure you have all of your dependencies? The step is in the tutorial here:

http://wiki.ros.org/indigo/Installati...

edit flag offensive delete link more

Comments

Yep I have tbb installed.

When I ran brew install tbb, the output is Warning: tbb-4.3-20150611 already installed

zoe gravatar imagezoe ( 2015-07-31 18:32:49 -0600 )edit

Well, then I'm not sure. Sorry I can't help more, maybe someone else will be able to help you. I'm using the same OS and versions but I'm unable to reproduce this error.

William gravatar imageWilliam ( 2015-08-03 18:56:24 -0600 )edit

Since tbb is installed, is the environment set up correctly to find it?

joq gravatar imagejoq ( 2015-10-15 08:08:51 -0600 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

Stats

Asked: 2015-07-24 17:16:32 -0600

Seen: 785 times

Last updated: Jul 27 '15