Ask Your Question
1

gmapping with turtlebot2 simulation does not create map

asked 2015-07-24 07:13:31 -0600

ana+ gravatar image

Hello:

I am running ros indigo 32 on the Nootrix virtual machine. I am trying to make a map and navigate it with a turtlebot2 simulated robot, according to this tutorial.

In a terminal, I run roslaunch turtlebot_gazebo turtlebot_world.launch

In another terminal, I run roslaunch turtlebot_gazebo gmapping_demo.launch. It runs, but after a while, I get this message: [ WARN] [1437734908.414750431, 97.100000000]: MessageFilter [target=odom ]: Dropped 100.00% of messages so far. Please turn the [ros.gmapping.message_notifier] rosconsole logger to DEBUG for more information.

In a third terminal, I run roslaunch turtlebot_rviz_launchers view_navigation.launch. Rviz opens, and in Global Options, the fixed frame is set to map. The map element of rviz appears in yellow, with a "No map received" message.

If I open another terminal with roslaunch kobuki_keyop keyop.launch, the robot moves both in Gazebo and rviz, but in rviz there is no trace of the readings of the sensors; if I try to store the map with rosrun map_server map_saver -f mymap, I get a "Waiting for the map".

I have checked the tf tree with rosrun tf view_frames, and the tree seems to be completely connected (I am a newbie so it seems I cannot attach an image yet); at least the tree has a map -> odom -> basefootprint -> base_link path on it.I have made this source source /opt/ros/indigo/setup.bash in every terminal and before every roslaunch.

I have been googling and looking for help, but i can't find where the problem is. I would really appreciate any help you may offer.

Thanks a lot in advance, Ana+

edit retag flag offensive close merge delete

Comments

I tried this too, and again the same result.

I checked the /map topic (rqt_graph, rosnode info slam_gmapping / rosnode info rviz), and it's connected. But rosrun tf tf_echo /map /odom always return 0 values, even if the robot moves with kobuki node

ana+ gravatar imageana+ ( 2015-07-24 13:27:21 -0600 )edit

1 Answer

Sort by » oldest newest most voted
1

answered 2015-07-26 12:10:48 -0600

ana+ gravatar image

Finally I made it work with the solution to this different problem. I made a complete report of the problem, both in Spanish and English.

edit flag offensive delete link more

Comments

I've got exactly the same situation as yours, and without your super detailed report I couldn't have solved the problem so quickly. Thank you so much! :)

Clack gravatar imageClack ( 2016-03-05 01:43:01 -0600 )edit

Thank you for your kind comment :)

ana+ gravatar imageana+ ( 2016-03-15 06:07:19 -0600 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2015-07-24 07:13:31 -0600

Seen: 443 times

Last updated: Jul 24 '15