Ask Your Question
1

gscam error - "Failed to PAUSE stream, check your gstreamer configuration." and "Failed to initialize gscam stream!"

asked 2015-07-21 13:17:00 -0600

nelsoncampos gravatar image

updated 2015-07-22 11:38:19 -0600

Hello,

I tryed to launch a file on my computer that was working fine in another computer on my lab, something like Section 3.

I found some solutions like :

sudo chmod 777 /dev/video0

ll /dev/video*

The device should now have all the permissions:

crwxrwxrwx+ 1 root video 81, 0 Jul 21 18:36 /dev/video0

and I could launch it correctly with:

roslaunch gscam v4l.launch

but it fails, giving me the error:

[FATAL] [1437501492.196615126]: Failed to PAUSE stream, check your gstreamer configuration.
[FATAL] [1437501492.197344548]: Failed to initialize gscam stream!

.

I tryed everything and it just doesn't work.

P.S.: I have Ubuntu 12.04 32bit, ROS Groovy and libgstreamer0.10 if it matters.

. .

My launch file contains exactly this:

<launch>
  <!-- Set this to your camera's name -->
  <arg name="cam_name" value="creative_cam" />

  <!-- Start the GSCAM node -->
  <env name="GSCAM_CONFIG" value="v4l2src device=/dev/video0 ! video/x-raw-yuv,framerate=30/1,width=640,height=480 ! ffmpegcolorspace " />
  <node pkg="gscam" type="gscam" name="$(arg cam_name)">
    <param name="camera_name" value="$(arg cam_name)" />
    <remap from="camera/image_raw" to="$(arg cam_name)/image_raw" />
  </node>

  <!-- View the raw and rectified output -->
  <node pkg="image_view" type="image_view" name="creative_view" >
    <remap from="image" to="/$(arg cam_name)/image_raw" />
  </node>

</launch>

Thank you for your attention ,

Nelson

edit retag flag offensive close merge delete

2 Answers

Sort by ┬╗ oldest newest most voted
1

answered 2015-07-21 20:57:22 -0600

Do not export GSCAM_CONFIG="v4l2src device=/dev/video0 ! video/x-raw-rgb,framerate=30/1 ! ffmpegcolorspace" and roslaunch gscam v4l.launch in the same terminal.

http://answers.ros.org/question/211757/error-in-gscam/

edit flag offensive delete link more

Comments

Thank you PJLai but I only use one of those. i just put it in the launch file like the section 3 says. Should I also do the export in another terminal or it is not necessário to work?

nelsoncampos gravatar imagenelsoncampos ( 2015-07-22 06:27:23 -0600 )edit

Can you show me your v4l.launch? You can edit your question and paste it.

Po-Jen Lai gravatar imagePo-Jen Lai ( 2015-07-22 08:21:18 -0600 )edit

Hello again Po-Jen-Lai. I just edited the question.

This launch file works fine in other computer from my lab but not at mine.

"I have Ubuntu 12.04 32bit, ROS Groovy and libgstreamer0.10 if it matters." just formatted yesterday.

nelsoncampos gravatar imagenelsoncampos ( 2015-07-22 11:42:06 -0600 )edit

Your launch file works perfectly on my laptop, I cannot reproduce your problem...Do you have other error messages except for the two lines in your question? There's no enough info to debug.

Po-Jen Lai gravatar imagePo-Jen Lai ( 2015-07-24 02:18:13 -0600 )edit
0

answered 2016-09-13 11:34:14 -0600

Jhony Ferreira gravatar image

Try removing the commas on the env name row:

<env name="GSCAM_CONFIG" value="v4l2src device=/dev/video0 ! video/x-raw-yuv framerate=30/1 width=640 height=480 ! ffmpegcolorspace "/>

This change worked for me.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

Stats

Asked: 2015-07-21 13:17:00 -0600

Seen: 1,489 times

Last updated: Jul 22 '15