ROSARIA could not connect to Pioneer 3 robot [closed]

asked 2015-07-08 20:13:06 -0600

anirban gravatar image

updated 2015-07-08 20:23:56 -0600

Hi,

I am using rosaria package to connect to a pioneer 3 robot. I installed rosaria successfully and I was able to connect once. I am using ros version INDIGO and for Ubuntu 14.04. I am trying to connect to the robot using a usb-serial converter and in one terminal I ran roscore and another with the following

$ rosrun rosaria RosAria _port:=/dev/ttyS0

Usually while connecting to the robot it shows Syncing 0 etc. But for me it is not coming after running the above command. The error I am getting is,

[ INFO] [1436403606.517125416]: RosAria: using port: [/dev/ttyUSB0]

Could not connect to simulator, connecting to robot through serial port /dev/ttyUSB0.

ArSerialConnection::open: Could not open serial port '/dev/ttyUSB0' | ErrorFromOSNum: 2 ErrorFromOSString: No such file or directory

Could not connect, because open on the device connection failed.

Failed to connect to robot.

[ERROR] [1436403606.539456347]: RosAria: ARIA could not connect to robot! (Check ~port parameter is correct, and permissions on port device.)

*[FATAL] [1436403606.539599263]: RosAria: ROS node setup failed... *

Any help is appreciated.

edit retag flag offensive reopen merge delete

Closed for the following reason duplicate question by anirban
close date 2015-07-10 18:10:03.926692

Comments

Did you try sudo chmod 777 -R /dev/ttyUSB0?

allenh1 gravatar imageallenh1 ( 2015-07-09 00:16:46 -0600 )edit
1

for some reason it's using /dev/ttyUSB0 instead of /dev/ttyS0. Can you try again using the rosrun command (rather than roslaunch) with _port:=/dev/ttyS0, and check the "using port:" message? You can also run rosparam get /RosAria/port to see what is stored in ROS.

ReedHedges gravatar imageReedHedges ( 2015-07-09 14:03:12 -0600 )edit

sudo chmod 777 -R /dev/ttyUSB0

worked for me. Thanks very much. I just got it worked.

anirban gravatar imageanirban ( 2015-07-10 18:07:24 -0600 )edit