Ask Your Question
0

I am unable to create the numpy_listener node

asked 2015-07-01 09:15:27 -0500

Shardul Rautmare gravatar image

updated 2015-07-02 21:15:39 -0500

i am using Ubuntu 14.04 LTS Indigo version, as shown in the numpy tutorial i have created the numpy_listener.py made it an executable, followed by the following commands

  1. source /opt/ros/indigo/setup.bash
  2. source ./devel/setup.bash
  3. catkin_make

after this when i type " rosrun numpy_tutorial numpy_listener.py" (roscore is running in another terminal) i get the error " package ' numpy_tutorial ' not found " , even though in my catkin workspace i have a folder titled numpy_tutorial with the numpy_listener.py file inside it

edit retag flag offensive close merge delete

Comments

Can you post the output of echo $ROS_PACKAGE_PATH when you experience this problem (please edit your question)? Also, do you have an error when sourcing any of the setup.bash files?

mgruhler gravatar image mgruhler  ( 2015-07-03 01:34:56 -0500 )edit

1 Answer

Sort by ยป oldest newest most voted
0

answered 2015-07-01 10:29:11 -0500

In step 2 you should be sourcing devel/setup.bash, not executing it.

edit flag offensive delete link more

Comments

1

Just to clarify: there should be a single space between . and devel/setup.bash. Clearer is perhaps to use source devel/setup.bash.

gvdhoorn gravatar image gvdhoorn  ( 2015-07-01 10:46:03 -0500 )edit

sorry, Dan , i made a mistake while writing the commands in the question... i had written source in front of command 2. i had used the same process for executing the rospy tutorial on creating a talker and a listener and it was successful

Shardul Rautmare gravatar image Shardul Rautmare  ( 2015-07-02 21:15:23 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

Stats

Asked: 2015-07-01 09:15:27 -0500

Seen: 44 times

Last updated: Jul 02 '15