Ask Your Question
0

Can't creake a package on fuerte

asked 2015-06-30 07:35:46 -0500

jossy gravatar image

updated 2015-06-30 08:01:54 -0500

I want to run this example. To do, I should create a package. But I can't create the package on ros-fuerte.

There are two ways package build type named catkin and rosbuild. Which one I should?

I tried both of them. My fuerte workspace is under home folder. Using catkin;

fuerte_workspace$ catkin_create_pkg using_markers roscpp visualization_msgs
Created file using_markers/CMakeLists.txt
Created file using_markers/package.xml
Created folder using_markers/include/using_markers
Created folder using_markers/src
Successfully created files in /home/user/fuerte_workspace/using_markers. Please adjust the values in package.xml.

Next step is :

You should be able to build the code with:
 $ cd %TOP_DIR_YOUR_CATKIN_WORKSPACE%
 $ catkin_make

I don't have any catkin workspace(or I can't find it). So, I tried to create a workspace using this [guide].(http://wiki.ros.org/catkin/Tutorials/create_a_workspace). But catkin_init_workspace doesn't work. Error message is fuerte_workspace$ catkin_init_workspace command not found .

How can I create a package on fuerte?

EDIT

I tried rosbuild+fuerte. The guide says that

Before getting started, let's create a scratch package to called using_markers, somewhere in your package path:
roscreate-pkg using_markers roscpp visualization_msgs

I tried roscreate-pkg using_markers roscpp visualization_msgs command, and I got an error. Error mesaage is below :

fuerte_workspace$ roscreate-pkg using_markers roscpp visualization_msgs
Traceback (most recent call last):
File "/opt/ros/fuerte/bin/roscreate-pkg", line 34, in <module>
import roscreate
 File "/opt/ros/fuerte/lib/python2.7/dist-packages/roscreate/__init__.py", line 36, in <module>
import roscreate.core
File "/opt/ros/fuerte/lib/python2.7/dist-packages/roscreate/core.py", line 40, in <module>
import pkg_resources
ImportError: No module named pkg_resources
edit retag flag offensive close merge delete

2 Answers

Sort by ยป oldest newest most voted
1

answered 2015-06-30 09:18:04 -0500

mgruhler gravatar image

updated 2015-06-30 09:19:09 -0500

I guess this error now comes from missing python-setuptools. Try:

sudo apt-get install python-setuptools

Then, call roscreate-pkg again.

But I'm with cyborg-x1 on this: Don't use Fuerte anymore. If you are on 12.04 and cannot upgrade due to whatever reason, try to go to Hydro at least.

edit flag offensive delete link more

Comments

I tried this command, everything is up-to-date. 0 upgraded, 0 newly installed, 0 to remove and 181 not upgraded.

jossy gravatar image jossy  ( 2015-06-30 09:44:32 -0500 )edit

I use lsd_slam, it tested only fuerte(ubuntu 12.04) and indigo(ubuntu 14.04).

jossy gravatar image jossy  ( 2015-06-30 09:48:49 -0500 )edit
1

Well, I suggest you upgrade the 181 not upgraded packages anyway ;-) But then I don't know what could be the problem.

maybe try:

sudo apt-get install python-pkg-resources python-setuptools --reinstall
mgruhler gravatar image mgruhler  ( 2015-06-30 10:13:51 -0500 )edit

You might also give pip a shot.

pip install -U setuptools --upgrade

Also, fuerte is EOL. Is there a particular reason you're sticking with Fuerte?

allenh1 gravatar image allenh1  ( 2015-07-07 19:44:19 -0500 )edit
1

answered 2015-06-30 07:49:04 -0500

updated 2015-06-30 07:51:49 -0500

I guess fuerte was the distribution before catkin arrived. So when I am right there are no catkin commands in fuerte.

Actually that means if you are continuing to use fuerte (I am not sure if that is recommended) you would have to use rosbuild instead of catkin.

(May anybody correct me if I am wrong)

edit flag offensive delete link more

Comments

I tried rosbuild. I just edit my question text. I can't create a package using rosbuild.

jossy gravatar image jossy  ( 2015-06-30 08:02:36 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2015-06-30 07:35:46 -0500

Seen: 284 times

Last updated: Jun 30 '15