Eclipse: Project Builds but no binaries only for ROS imports

asked 2015-06-10 12:09:57 -0600

raghav.rao32 gravatar image

updated 2015-06-23 17:14:23 -0600

(Ubuntu 14.04, Eclipse Kepler, Ros Indigo) Found this problem while using the IDE guide on ROSWiki. After checking multiple forum threads with similar titles, none of the solutions posted have worked. I am new to ROS and C++, so I'm not sure why this is happening. (I open eclipse from terminal, after source devel/setup.bash and using the bash -i -c "eclipse" command suggested in the wiki)

Here is what I've tried:

  • Setting my binary parser (I checked various combinations of checking Elf and GNU Elf, since I'm using linux). I created a new C/C++ project and wrote a Hello World program, which builds fine, and generates binaries. Only the ROS (beginner_tutorial) project I imported doesn't have binaries
  • Clicking 'Build'/Ctrl+B. It says Build Finished took 282 ms. Many Posters had forgotten this step.

All the forum posts on this topic I found either have no response or suggest the above two. Here are some additional steps I took:

  • Rebuilding the Index
  • Combinations of Clean/Refresh/Build/ closing and re-opening the project, closing eclipse and re-opening with bash -i -c "eclipse"
  • Going to Project -> Properties -> C/C++ General -> Preprocessor includes -> CDT GCC Built-in Compiler Settings [shared]
  • Making sure my environment variables are correct (ROS_ROOT, ROS_PACKAGE_PATH, PATH, PYTHONPATH). They are.
  • Deleting and re-importing the project
  • Changing the workspace to one that is not catkin_ws.

None of these have worked. I tried going to Run Configurations to see if anything shows up in Search Project, but the list of Binaries is empty. I still find it strange that Eclipse generates/identifies the binaries for other projects, just not the ROS ones.

Thank you very much for any assistance.

edit retag flag offensive close merge delete

Comments

Still no answers? I've tried pretty much everything at this point. For now I'm using the binaries from catkin_ws/devel/lib that catkin_make generates but it's a huge hassle to rebuild and edit. I was hoping someone could help out

raghav.rao32 gravatar imageraghav.rao32 ( 2015-06-23 17:13:47 -0600 )edit

Hi, did you manage to figure out how to do it? I'm having the same problem.

michalgn gravatar imagemichalgn ( 2016-10-23 14:23:34 -0600 )edit