Ask Your Question
0

no map receive, Gmappping with Velodyne HDL-32E [closed]

asked 2015-06-04 19:10:26 -0500

Tomoko gravatar image

Hi All!!

I really need your help!

I am trying to make a map using “Gmapping” package, however I could not receive any map data from it.

To make 3D scan data to 2D, I use but_velodyne_proc, then /odom date seem to be published correctly over /tf topics.

Also I checked /tf frame, then it seems fine. /velodyne(scan frame)-->/base_link-->/odom-->/map

But if I tried to visualize a map with rviz, they said "no map received" and "No tranceform [] to [map]"

I am new to ROS. Thank you for your time and I will appreciate any help!!

edit retag flag offensive reopen merge delete

Closed for the following reason duplicate question by Tomoko
close date 2015-06-08 16:04:12.647205

Comments

Thank you very much, Horse-man! It worked, However I had another problem the odom data jumped a lot,,,,then not making a proper map. Anyway it is another thing, I will open a new question, Thank you again.

Tomoko gravatar imageTomoko ( 2015-06-08 16:03:29 -0500 )edit

you're welcome

Horse-man gravatar imageHorse-man ( 2015-06-10 16:20:01 -0500 )edit

1 Answer

Sort by » oldest newest most voted
0

answered 2015-06-05 16:22:08 -0500

Horse-man gravatar image

Did you specify the fixed frame in rviz ? To set the fixed frame see the section Global Options in the left panel. Generally we choose either /base_link or /map frame as a fixed frame.

edit flag offensive delete link more

Comments

I also the same condition "no map received" but I fixed frame in rviz? How can I check what is wrong?

nunuwin gravatar imagenunuwin ( 2019-06-11 14:35:08 -0500 )edit

Question Tools

1 follower

Stats

Asked: 2015-06-04 19:00:13 -0500

Seen: 494 times

Last updated: Jun 04 '15