Ask Your Question
0

roscore works normal from command line but it does not work over ssh

asked 2015-05-21 04:14:55 -0500

huseyin gravatar image

I just recently installed ros-indigo on raspberry pi. The roscore works fine when I run it from the raspberry pi itself. But when i try to run it from my laptop through ssh i get the following error:

terminate called after throwing an instance of 'std::runtime_error' what(): locale::facet::_S_create_c_locale name not valid

After termination of process rosout it restarts over and over again.

Btw sorry for my bad English. It is not my native.

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
1

answered 2015-05-21 19:57:09 -0500

tfoote gravatar image

Did you set your locale as specified in the install instructions? http://wiki.ros.org/indigo/Installati...

edit flag offensive delete link more

Comments

yeah you are right. Problem was in the locales i changed raspberry pi 's local. Thank you very much.

huseyin gravatar image huseyin  ( 2015-05-22 07:18:13 -0500 )edit

Glad that it's working. Please mark this answer as accepted(using the checkmark at left) so that others know that your problem has been solved without reading your comment.

tfoote gravatar image tfoote  ( 2015-05-22 09:45:21 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

Stats

Asked: 2015-05-21 04:09:47 -0500

Seen: 519 times

Last updated: May 22 '15