Ask Your Question
0

How can I use Kinect v2 with ROS in Ubuntu 14.04

asked 2015-05-18 01:15:31 -0500

Ros_junior gravatar image

updated 2015-05-18 02:25:27 -0500

Hello, I'm a Korean and I have some problem to understand the datas which are in this website in English.

But I try to understand .

Anyway, My problem is how to use kinect v2 for using SLAM in ROS

I tried to follow manuals from all most forum ,blogs and googling. And, Write at terminal in Ubuntu.

Some sentances were right working , but after other sentances ,

My computer said

I need to install a tool for using Kinect v2.

Help me , please and I will thank you if you give me a manual which I can follow easily.

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
0

answered 2015-05-18 03:25:16 -0500

updated 2015-05-28 04:29:45 -0500

Hello, I think we'll need more information to help, can you specify more clearly which packages you are trying to use and what error messages you have ? Some people got the kinect v2 working on ROS : http://www.ros.org/news/2014/09/micro... . Do you really have to use kinect v2 to do that ? Otherwise, you could do 2D SLAM quite easily with a kinect v1 on ROS.

EDIT : I managed to build and install libfrennect2 : While installing libfrennect2, configure of libusb failed because some dependencies were missing, so no Makefile was generated, and the script install_ubuntu.sh failed. If you have this error saying libusb.h is missing, try this first, as described in the iai_kinect2 github page , it worked for me :

sudo apt-get install build-essential libturbojpeg libtool autoconf libudev-dev cmake mesa-common-dev freeglut3-dev libxrandr-dev doxygen libxi-dev libopencv-dev
edit flag offensive delete link more

Comments

I really thank you for your advise. I try to follow your link. and I have some wodering parts.

Ros_junior gravatar image Ros_junior  ( 2015-05-25 13:18:48 -0500 )edit

Oh, Why I can not upload my screen shot ??? ..... Sorry, I just ask you with writing.

I opened this link ' https://github.com/code-iai/iai_kinect2 '

and read this title
Modifications to Upstream libfreenect2

CMakeLists.txt: Replace line 48 to 50 with # LibUSB GET_FILENAME_C

Ros_junior gravatar image Ros_junior  ( 2015-05-25 13:30:02 -0500 )edit

and I command in my turminal

$cd ~/catkin_ws/src

$gedit CMakeLists.txt

Ros_junior gravatar image Ros_junior  ( 2015-05-25 13:31:56 -0500 )edit

and then copy the ' #LibUSB GET_ ~~~~~ bla bla bla'

and paste it in CMakeLists.txt 48~ 50 line

Do I follow right way???

Ros_junior gravatar image Ros_junior  ( 2015-05-25 13:35:27 -0500 )edit

link text

here is screen shot link

Ros_junior gravatar image Ros_junior  ( 2015-05-25 13:38:12 -0500 )edit

And, I have to use Kinect V2 beacause I can't buy v1 anymore in Korea T T

Ros_junior gravatar image Ros_junior  ( 2015-05-25 13:40:25 -0500 )edit

I can't open your screenshot. I just received my kinect2 so I'll try as well and let you know if that works.

Cyril_J gravatar image Cyril_J  ( 2015-05-27 10:15:37 -0500 )edit

Thank you T.T . I'm waiting your answer

Ros_junior gravatar image Ros_junior  ( 2015-05-27 10:59:37 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

2 followers

Stats

Asked: 2015-05-18 01:14:52 -0500

Seen: 2,172 times

Last updated: May 28 '15