roscore error, ROS_MASTER_URI

asked 2015-05-14 06:33:13 -0500

htlbydgod gravatar image

updated 2015-05-14 09:43:12 -0500

gvdhoorn gravatar image

Hello! Everyone. I have encountered an roscore error. When I run roscore, the screenshot is presented as follows.

image description

I only open a terminal, and thus I am sure I do not run another roscore. Besides, when I run roslaunch, it does not print an error, but all wait. I guess whether the ROS_MASTER_URT set is right or not. Thanks in advance and best regards. The error is further presented as bleow.

roscore cannot run as another roscore/master is already running. 
Please kill other roscore/master processes before relaunching.
The ROS_MASTER_URI is http://yxg-Inspiron-5443:11311/
The traceback for the exception was written to the log file
edit retag flag offensive close merge delete



We cannot see your image. In any case, please avoid using screenshots to post console output. Just copy/paste it into your question.

gvdhoorn gravatar image gvdhoorn  ( 2015-05-14 09:44:05 -0500 )edit

Thanks gvdhoorn for your time and suggestion. I will take notice of it, and thanks you again. Besides, the error has been solved. Best regards.

htlbydgod gravatar image htlbydgod  ( 2015-05-14 20:54:07 -0500 )edit

@htlbydgod how did you solve this?

ToughMind gravatar image ToughMind  ( 2017-06-04 22:01:29 -0500 )edit