Ask Your Question
0

How do I built the ros-indigo-pointgrey-camera-driver aptitude package for the Ubuntu trusty armhf platform?

asked 2015-05-13 17:09:11 -0500

Bryce gravatar image

It's pretty simple. It seems that only ros-jade-pointgrey-camera-driver aptitude package is available for armhf. I'd rather continue to use indigo if possible, and I know that ros-indigo-pointgrey-camera-driver is available on other platforms.

edit retag flag offensive close merge delete

Comments

Why do you want to build the apt package? Why not just install the package from source?

ahendrix gravatar image ahendrix  ( 2015-05-13 18:01:59 -0500 )edit

I have actually tried that, and I get errors when I run the camera.launch file:

Could not find library corresponding to plugin pointgrey_camera_driver/PointGreyCameraNodelet.

Bryce gravatar image Bryce  ( 2015-05-13 18:35:04 -0500 )edit

2 Answers

Sort by ยป oldest newest most voted
0

answered 2015-05-13 19:12:43 -0500

ahendrix gravatar image

When I was building Indigo packages for armhf six months ago, the pointgrey driver included a binary driver that only supported x86, so it didn't build on ARM.

It looks like this has been resolved in a recent release ( https://github.com/ros-drivers/pointg... ), but the fix hasn't made it back to the Indigo builds for armhf yet.

You should be able to check out the latest version from source, build and run it on armhf. Perhaps you just forgot to build it before you tried to run it?

edit flag offensive delete link more

Comments

Thanks, turns out I'm not used to the new catkin_make system. There's some setup.bash script that catkin_make generates that I needed to source in order for all the paths to line up. That said, I'm not too sure this package is working well on armhf, but that's another conversation.

Bryce gravatar image Bryce  ( 2015-05-14 12:48:59 -0500 )edit
-1

answered 2015-07-30 16:34:29 -0500

Thomas10111 gravatar image

To run it on the Jeston board (ARM chip) I had to do: clone github with git etc. sudo apt-get install ros-indigo-roslint source devel/setup.bash catkin_make

Cheers, Thomas

edit flag offensive delete link more

Comments

1

Why did you have to install roslint to make the pointgrey driver work? That's not a dependency that it should have, and it doesn't seem like the right way to solve this issue.

ahendrix gravatar image ahendrix  ( 2015-08-08 16:26:30 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

Stats

Asked: 2015-05-13 17:09:11 -0500

Seen: 569 times

Last updated: May 13 '15