Speed up hector_exploration_planner?

asked 2015-05-12 21:20:16 -0500

Trexter101 gravatar image

I am running exploration on a Raspberry Pi 2 along with a few other programs. However, no matter what I try the doExploration function takes 20 seconds to complete. Is this really the case or is there a setting that I am missing somewhere.

Also I am getting this error constantly:

Costmap2DROS transform timeout. Current time: 1431482795.3188, global_pose stamp: 1431482795.0172, tolerance: 0.3000

Could not get robot pose, cancelling reconfiguration

Please is there a way to speed up exploration and is this error slowing it.

Also thanks so much to team hector and Stefan.

edit retag flag offensive close merge delete