Ask Your Question
1

MOVEIT+GAZEBO: joint_states namespace and move_group problem

asked 2015-05-03 12:23:11 -0500

nir gravatar image

Hi all, I'm trying to configure moveit + gazebo, so far I managed to configure the setup assistant for a new robot as the tutorial shows. My problem is that move_group node listen to "/joint_states" and the GAZEBO publish i with a namespace i.e /robot/joint_states. (I figured it out by following the kinematics tutorial so as by typing "rostopic list -v").

So, my question is how do I configure move_group to listen to /robot/joint_states.

My github repository: https://github.com/nirlevi5/robo-serv... Attached an Example rqt_graph photo.

Thanks Nir

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
2

answered 2015-05-03 22:13:26 -0500

rorromr gravatar image

A simple solution is add a remap entry on move_group.launch

<node name="move_group" ...
...
<remap from="/joint_states" to="/your_robot/joint_states" />
</node>
edit flag offensive delete link more

Comments

Great, It works now. Now the Rviz plans based on the gazebo model configuration. But still, when I'm following the kinematics tutorial I get joint values equals to zero, I thought it should take it from the /myrobot/joint_states topic?

nir gravatar image nir  ( 2015-05-04 02:40:08 -0500 )edit

Currently I have the same issue, this topic shows some information about the problem https://groups.google.com/a/rethinkro...

rorromr gravatar image rorromr  ( 2015-05-18 22:35:31 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

Stats

Asked: 2015-05-03 12:23:11 -0500

Seen: 1,104 times

Last updated: May 03 '15