Ask Your Question
0

rosrun beginner_tutorials error

asked 2015-04-23 20:15:41 -0500

s1 gravatar image

I am following the beginner tutorial, when I run

roscore

then from within catkin_ws I run

catkin_make

rosrun beginner_tutorials talker

I am geting an error

[rospack] Error: package 'beginner_tutorials' not found

what would cause this error?
could it be file ownership? so far everything was thru command line but after i installed eclipse this error started happening.

when i run

rosrun roscpp_tutorials talker

it runs ok but I am not sure where this package resides.

FIXED : http://answers.ros.org/question/71260...

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
0

answered 2015-04-24 09:04:53 -0500

aak2166 gravatar image

updated 2015-04-24 09:05:26 -0500

From within the catkin_ws: source devel/setup.bash, then try to rosrun again.

edit flag offensive delete link more

Comments

when do i need to "source" catkin_ws? in other words what would cause me to have to do this?

s1 gravatar image s1  ( 2015-04-24 09:28:15 -0500 )edit
1

So the script setup.bash is a config script that will set some environment variables. Without those variables being set then ROS is not aware of the new executables that you have created during build.

aak2166 gravatar image aak2166  ( 2015-04-24 09:48:23 -0500 )edit
1

source the environment

dmngu9 gravatar image dmngu9  ( 2015-04-25 02:26:59 -0500 )edit

I thought catkin_make took care of compiling node changes

s1 gravatar image s1  ( 2015-04-27 09:55:29 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2015-04-23 19:25:03 -0500

Seen: 549 times

Last updated: Apr 24 '15