Ask Your Question
2

Catkin_make Error "No rule to make target /usr/lib/libcxsparse.so.2.2.3', needed by/home/zarneel/rgbdslam_catkin_ws/devel /lib/rgbdslam/rgbdslam'. Stop"

asked 2015-04-18 10:44:50 -0500

Zari gravatar image

updated 2015-04-19 10:16:49 -0500

Can any one solve this issue?

Base path: /home/zarneel/rgbdslam_catkin_ws

Source space: /home/zarneel/rgbdslam_catkin_ws/src

Build space: /home/zarneel/rgbdslam_catkin_ws/build

Devel space: /home/zarneel/rgbdslam_catkin_ws/devel

Install space: /home/zarneel/rgbdslam_catkin_ws/install

Running command: "make cmake_check_build_system" in "/home/zarneel/rgbdslam_catkin_ws/build"

Running command: "make -j4 -l4" in "/home/zarneel/rgbdslam_catkin_ws/build"

[ 0%] [ 0%] [ 0%] [ 0%] Built target _rgbdslam_generate_messages_check_deps_rgbdslam_ros_ui_f

Built target _rgbdslam_generate_messages_check_deps_rgbdslam_ros_ui_b

Built target _rgbdslam_generate_messages_check_deps_rgbdslam_ros_ui_s

Built target _rgbdslam_generate_messages_check_deps_rgbdslam_ros_ui

[ 13%] Built target siftgpu_proj

[ 26%] [ 26%] Built target rgbdslam_generate_messages_lisp

Built target rgbdslam_generate_messages_cpp

[ 35%] Built target rgbdslam_generate_messages_py

[ 35%] [ 35%] Built target rgbdslam_gencpp

Built target rgbdslam_generate_messages

make[2]: * No rule to make target /usr/lib/libcxsparse.so.2.2.3', needed by/home/zarneel/rgbdslam_catkin_ws/devel /lib/rgbdslam/rgbdslam'. Stop.

make[1]: * [rgbdslam_v2-hydro/CMakeFiles/rgbdslam.dir/all] Error 2

make: * [all] Error 2

Invoking "make -j4 -l4" failed

edit retag flag offensive close merge delete

Comments

Which command do you execute?? Which package? ROS version? OS version? Please post more information, otherwise there won't be anyone who can help you....

Wolf gravatar image Wolf  ( 2015-04-19 05:27:42 -0500 )edit

I got this error when I run command "catkin_make" I am trying to run rgbdslam_v2 on ROS Indigo.Ubuntu version 14.04

Complete execution with error is mentioned above.

Zari gravatar image Zari  ( 2015-04-19 07:52:45 -0500 )edit

I followed the same steps mentioned here http://felixendres.github.io/rgbdslam...

Zari gravatar image Zari  ( 2015-04-19 08:20:58 -0500 )edit

1 Answer

Sort by ยป oldest newest most voted
2

answered 2015-05-18 18:48:32 -0500

DikobrAz gravatar image

I've changed the line in the src/rgbdslam_v2/CMakeLists.txt to the following:

SET(LIBS_LINK GL GLU cholmod /usr/lib/x86_64-linux-gnu/libcxsparse.so.3.1.2 #/usr/lib/libcxsparse.so.2.2.3 ${G2O_LIBRARIES} ${QT_LIBRARIES} ${QT_QTOPENGL_LIBRARY} ${GLUT_LIBRARY} ${OPENGL_LIBRARY} ${OpenCV_LIBS})

And the package compiled. I guess author haven't made a proper cmake search module for it just yet.

edit flag offensive delete link more

Comments

1

Thanks for reply.I just replaced the newer version with older one and it works fine for me.

Zari gravatar image Zari  ( 2015-05-19 17:51:20 -0500 )edit

Worked for me, thanks a lot! Just one thing, you forgot one closing bracket and that might generate weird error messages

Mr. Kro gravatar image Mr. Kro  ( 2016-05-10 01:57:31 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

Stats

Asked: 2015-04-18 10:44:50 -0500

Seen: 3,416 times

Last updated: Apr 19 '15