Ask Your Question
0

libpointmatcher not found

asked 2015-04-07 22:15:35 -0600

HELPME gravatar image

updated 2015-04-07 22:16:02 -0600

I was trying to install ethzasl_icp_mapping (Indigo branch) but I keep getting the following error:

CMake Error at /opt/ros/indigo/share/catkin/cmake/catkinConfig.cmake:75 (find_package):
  Could not find a package configuration file provided by "libpointmatcher"
  with any of the following names:

    libpointmatcherConfig.cmake
    libpointmatcher-config.cmake

  Add the installation prefix of "libpointmatcher" to CMAKE_PREFIX_PATH or
  set "libpointmatcher_DIR" to a directory containing one of the above files.
  If "libpointmatcher" provides a separate development package or SDK, be
  sure it has been installed.

can anyone help me with it?

edit retag flag offensive close merge delete

Comments

Have you done a rosdep install?

BennyRe gravatar imageBennyRe ( 2015-04-08 01:20:32 -0600 )edit

yes.but there is missing resource.

HELPME gravatar imageHELPME ( 2015-04-08 01:36:32 -0600 )edit

Can you post the rosdep command you used and the exact error message, please?

BennyRe gravatar imageBennyRe ( 2015-04-08 06:05:31 -0600 )edit

1 Answer

Sort by ยป oldest newest most voted
0

answered 2015-08-06 10:32:47 -0600

tinokl gravatar image

unfortunately i go the same problem, when running catkin_make on this pkg. I am on indigo, 64bit ubuntu and installed libpointmatcher and libnabo from source.

The rosdep command looks as follows: rosdep install ethzasl_icp_mapping

and results in: #All required rosdeps installed successfully

when i make: rosmake ethzasl_icp_mapping

it delievers following output:

[ rosmake ] rosmake starting...
[ rosmake ] Packages requested are: ['ethzasl_icp_mapping']
[ rosmake ] Logging to directory /home/kl/.ros/rosmake/rosmake_output-20150806-172611
[ rosmake ] Expanded args ['ethzasl_icp_mapping'] to: []
[ rosmake ] WARNING: The stack "libnabo" was not found. We will assume it is using the new buildsystem and try to continue...
[ rosmake ] WARNING: The stack "libpointmatcher" was not found. We will assume it is using the new buildsystem and try to continue...
[ rosmake ] WARNING: The stack "catkin" was not found. We will assume it is using the new buildsystem and try to continue...
[ rosmake ] Results:
[ rosmake ] Built 0 packages with 0 failures.
[ rosmake ] Summary output to directory

Hope someone can help me out!

thank in advance

edit flag offensive delete link more

Comments

Did you set up your rosbuild workspace correctly on top of your catkin workspace?

BennyRe gravatar imageBennyRe ( 2015-08-10 02:11:36 -0600 )edit

actual i didn't do that. I thought it is done by cloning it into my catkin workspace and checking out the indigo_devel branch (and of course doing a catkin_make...) isnt it completly catkinized? how should it be?

Sorry, i am little confused :)

tinokl gravatar imagetinokl ( 2015-08-17 05:31:34 -0600 )edit

Well, you're using the rosmake command. So, no it's not completely catkinized.

BennyRe gravatar imageBennyRe ( 2015-08-26 02:21:56 -0600 )edit
1

so now it works but what i did was different: created catkin_ws - cloned ethasl_icp_mapping indigo branch, libnabo and libpointmatcher into ws. then made everything with catkin_make_isolated. now everything compiles fine under catkin with ros jade

tinokl gravatar imagetinokl ( 2015-09-07 04:50:28 -0600 )edit

Following tinokl's method, I successfully compiled the package with ros indigo

libing64 gravatar imagelibing64 ( 2016-03-26 21:59:57 -0600 )edit

tinoki or libing64 --- were you required to change any of the directory/cmake file names? I've tried following these instructions and have had no luck getting either catkin_make or catkin_make_isolate to work.

ladlibertine gravatar imageladlibertine ( 2016-11-16 15:37:25 -0600 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

2 followers

Stats

Asked: 2015-04-07 22:15:35 -0600

Seen: 526 times

Last updated: Apr 07 '15