Map is not correct

asked 2015-04-07 11:24:05 -0500

maha gravatar image

hello, I'm trying to build my first map in ros.. and i got the map looks so weird, it only has white and black dots making a weird pattern. this pattern becomes bigger when i take more time scanning the area using my Kinect Camera to laser.. However, I get this error in the gmapping terminal
Warning: TF_OLD_DATA ignoring data from the past for frame camera_depth_frame at time 1.42.....+09 according to authority unknown_publisher ... while playing the bag


I tried the rostopic pub /reset_time std_msgs/Empty but i still get the same warning.

can anyone help please? why am i getting only dots? and is this warning related or not?

Thank you.

edit retag flag offensive close merge delete

Comments

Can you post a screenshot of the map that is being generated? Unfortunately, there are many ways that mapping can fail. Perhaps if we see the failed output, we can give some suggestions. Starting with very small maps is usually best, and only going for large areas once the tiny maps are working.

Morgan gravatar image Morgan  ( 2015-04-07 13:16:39 -0500 )edit

those two maps i got.. zoom the picture to see the dots

maha gravatar image maha  ( 2015-04-07 14:10:38 -0500 )edit

yea this is what i did.. i scanned only less than 3 square meters area and there was two tables to see and so that's it.

maha gravatar image maha  ( 2015-04-07 14:11:58 -0500 )edit