Ask Your Question
1

how to use the frontier_exploration package

asked 2015-04-07 08:10:40 -0600

Swan Baigne gravatar image

updated 2015-04-15 04:44:12 -0600

Hello I am currently working on a project where a turtlebot robot have to create a map of a room without human intervention. I am working with Ubuntu 14.04 LTS with ROS Indigo. I found the Frontier_Exploration package which, if i understood the documentation well, should allow me to do this mapping, but i was not able to make it work.

So i had some questions :

  • What nodes and topics does the global_map.launch file need in order to works ?
  • How to tell the turtlebot to start the exploration ?

EDIT : One last question, i just wanted to know where you have to change the obstacle's width. For now my robot cant go though all the room i want to map because there is 2 wall too close one to each other, and the package consider the robot cant go though ( even when it is amply possible ). I tried changing the inflation_radius parameter in global_map.launch (frontier_exploration/launch ) and in costmap_common_params.yaml (turtlebot_navigation/param ) but it don't change the radius.

EDIT 2 : Solved it, the parameter to change was indeed inflation_radius, but i forgot to change it in the laser/costman_comon_param.yaml

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
2

answered 2015-04-07 09:03:27 -0600

paulbovbel gravatar image

updated 2015-04-08 15:55:40 -0600

Check out the husky's frontier exploration demo ( http://wiki.ros.org/husky_navigation/... ), and you can work backwards from the launch files to port it to a turtlebot.


EDIT: Thanks for picking that up, turns out there was a strange issue that was preventing the explore_client node from compiling and working properly in the binary release. It's now been fixed, but hasn't been synced to the public ROS packages yet, so please either run frontier_exploration from source, from get the new release from ROS shadow repos , or from the Clearpath packages.

PS Make sure you have the 'Exploration' Markers turned on in the husky_viz rviz config

edit flag offensive delete link more

Comments

Thanks for your answer, but i have the same problem when trying to use this tutorial : i create the polygon with the "Publish Point" button, but nothing happens. My exploration_demo.launch terminal show : "Laser Pose= 0.00145 0.0035 Registering Scans:Done" repeated every second

Swan Baigne gravatar imageSwan Baigne ( 2015-04-08 02:07:52 -0600 )edit

Perfect, i ran the package from ROS shadow repos and it works fine, thanks for the answers !

Swan Baigne gravatar imageSwan Baigne ( 2015-04-09 07:07:05 -0600 )edit

i am having the very same problem... i ran through all of your instruction and it still only logs (Pose=0.000874 0.000812 Registering Scans: Done.) does not move but i get a partial map reading at its stationary place. Kobuki + URG lidar. help would be much appreciated. - but husky move_base works!

sobot gravatar imagesobot ( 2015-05-05 06:39:30 -0600 )edit

Did you make sure you have changed the right parameters in exploration.launch or other files to adapt to your robot ? Also try to download the package again from each of the repertory mentioned in paulbovel's answer : it's possible you dont have the right version

Swan Baigne gravatar imageSwan Baigne ( 2015-05-06 01:20:48 -0600 )edit

@Swan Baigne I downloaded and checked the fixed package, as far as gmapping and move_base im getting good results. what do i need to change in exploration.launch? .yaml files? i played around a lot but maybe im missing something. do you have your working config / files to share? i be very thankful

sobot gravatar imagesobot ( 2015-05-06 03:44:34 -0600 )edit

After thinking about it, exploration.launch shouldn't change the way the package work. Could you put a list of the nodes running ?

Swan Baigne gravatar imageSwan Baigne ( 2015-05-06 05:21:49 -0600 )edit

Sure, here: /base_footprint_to_base_link
/base_link_to_base_laser_link
/diagnostic_aggregator
/explore_client
/explore_server
/laser_scan
/mobile_base
/mobile_base_nodelet_manager
/move_base
/rosout
/slam_gmapping

sobot gravatar imagesobot ( 2015-05-06 07:17:04 -0600 )edit

Explore_Server is running, so there should not have any problem ... Try to download from Clearpath Packages because i can confirm that normal and shadow version don't works. And when you create your polygon and close it, does the polygon become red ? if not it's a problem with the package.

Swan Baigne gravatar imageSwan Baigne ( 2015-05-06 07:48:03 -0600 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2015-04-07 08:10:40 -0600

Seen: 2,406 times

Last updated: Apr 15 '15