Ask Your Question
0

rapp manager errors turtlebot minimal.launch

asked 2015-03-10 11:21:21 -0500

dfk gravatar image

updated 2015-03-10 11:22:04 -0500

Hi,

I just installed ubuntu 14.04.2 (trusty) on my netbook, and followed the directions here ( http://wiki.ros.org/indigo/Installati... ) to install ROS indigo. Then I installed the TurtleBot packages here ( http://wiki.ros.org/turtlebot/Tutoria... ). I test the setup by running roscore on the master machine (different physical machine, but same setup as described), and then minimal.launch on the netbook. It seems to be working for about 15 seconds, but then it crashes when the rapp manager times out.

Does anybody know what might be going on? At first I thought it was a problem with communication between machines, but they can ping each other fine and all environment variables seem to be set:

asdf@asdf:~$ printenv | grep ROS ROS_ROOT=/opt/ros/indigo/share/ros ROS_PACKAGE_PATH=/opt/ros/indigo/share:/opt/ros/indigo/stacks:/home/asdf/thesis/ROS/helloworld/turtlebot_driver_test/:/home/asdf/thesis/LoadManager/catkin_ws/ ROS_MASTER_URI=http://squirrel:11311 ROS_HOSTNAME=asdf ROSLISP_PACKAGE_DIRECTORIES= ROS_DISTRO=indigo ROS_IP=10.8.190.94 ROS_ETC_DIR=/opt/ros/indigo/etc/ros

Here's the output of minimal.launch:

asdf@asdf:~slaunch turtlebot_bringup minimal.launch ... logging to /home/asdf/.ros/log/dfa94692-c740-11e4-8dbb-001c230e5560/roslaunch-asdf-2863.log Checking log directory for disk usage. This may take awhile. Press Ctrl-C to interrupt Done checking log file disk usage. Usage is <1GB.

started roslaunch server http://asdf:59137/

SUMMARY

PARAMETERS * /app_manager/auto_rapp_installation: False * /app_manager/auto_start_rapp: * /app_manager/capability_server_name: capability_server * /app_manager/local_remote_controllers_only: False * /app_manager/rapp_package_blacklist: [] * /app_manager/rapp_package_whitelist: ['rocon_apps', 't... * /app_manager/remote_controller_blacklist: [] * /app_manager/remote_controller_whitelist: [] * /app_manager/robot_icon: turtlebot_bringup... * /app_manager/robot_name: turtlebot * /app_manager/robot_type: turtlebot * /app_manager/screen: True * /app_manager/simulation: False * /bumper2pointcloud/pointcloud_radius: 0.24 * /capability_server/blacklist: ['std_capabilitie... * /capability_server/defaults/kobuki_capabilities/KobukiBringup: kobuki_capabiliti... * /capability_server/defaults/kobuki_capabilities/KobukiBumper: kobuki_capabiliti... * /capability_server/defaults/kobuki_capabilities/KobukiCliffDetection: kobuki_capabiliti... * /capability_server/defaults/kobuki_capabilities/KobukiLED1: kobuki_capabiliti... * /capability_server/defaults/kobuki_capabilities/KobukiLED2: kobuki_capabiliti... * /capability_server/defaults/kobuki_capabilities/KobukiLED: kobuki_capabiliti... * /capability_server/defaults/kobuki_capabilities/KobukiWheelDropDetection: kobuki_capabiliti... * /capability_server/defaults/std_capabilities/Diagnostics: turtlebot_capabil... * /capability_server/defaults/std_capabilities/DifferentialMobileBase: kobuki_capabiliti... * /capability_server/defaults/std_capabilities/LaserSensor: turtlebot_capabil... * /capability_server/defaults/std_capabilities/RGBDSensor: turtlebot_capabil... * /capability_server/defaults/std_capabilities/RobotStatePublisher: turtlebot_capabil... * /capability_server/defaults/turtlebot_capabilities/TurtleBotBringup: turtlebot_capabil... * /capability_server/nodelet_manager_name: capability_server... * /capability_server/package_whitelist: ['kobuki_capabili... * /cmd_vel_mux/yaml_cfg_file: /opt/ros/indigo/s... * /description: Kick-ass ROS turtle * /diagnostic_aggregator/analyzers/input_ports/contains: ['Digital Input',... * /diagnostic_aggregator/analyzers/input_ports/path: Input Ports * /diagnostic_aggregator/analyzers/input_ports/remove_prefix: mobile_base_nodel... * /diagnostic_aggregator/analyzers/input_ports/timeout: 5.0 * /diagnostic_aggregator/analyzers/input_ports/type: diagnostic_aggreg... * /diagnostic_aggregator/analyzers/kobuki/contains: ['Watchdog', 'Mot... * /diagnostic_aggregator/analyzers/kobuki/path: Kobuki * /diagnostic_aggregator/analyzers/kobuki/remove_prefix: mobile_base_nodel... * /diagnostic_aggregator/analyzers/kobuki/timeout: 5.0 * /diagnostic_aggregator/analyzers/kobuki/type: diagnostic_aggreg... * /diagnostic_aggregator/analyzers/power/contains: ['Battery', 'Lapt... * /diagnostic_aggregator/analyzers/power/path: Power System * /diagnostic_aggregator/analyzers/power/remove_prefix: mobile_base_nodel... * /diagnostic_aggregator/analyzers/power/timeout: 5.0 * /diagnostic_aggregator/analyzers/power/type: diagnostic_aggreg... * /diagnostic_aggregator/analyzers/sensors/contains: ['Cliff Sensor', ... * /diagnostic_aggregator/analyzers/sensors/path: Sensors * /diagnostic_aggregator/analyzers/sensors/remove_prefix: mobile_base_nodel... * /diagnostic_aggregator/analyzers/sensors/timeout: 5.0 * /diagnostic_aggregator/analyzers/sensors/type: diagnostic_aggreg... * /diagnostic_aggregator/base_path: * /diagnostic_aggregator/pub_rate: 1.0 * /icon: turtlebot_bringup... * /interactions/interactions: ['turtlebot_bring... * /interactions/pairing: True * /interactions/rosbridge_address: localhost * /interactions/rosbridge_port: 9090 * /mobile_base/base_frame: base_footprint * /mobile_base/battery_capacity: 16.5 * /mobile_base/battery_dangerous: 13.2 * /mobile_base/battery_low: 14.0 * /mobile_base/cmd_vel_timeout: 0.6 * /mobile_base/device_port: /dev ... (more)

edit retag flag offensive close merge delete

Comments

Odd. Now I installed rocon on the master and get this error:

/opt/ros/indigo/lib/python2.7/dist-packages/bondpy/bondpy.py:114: SyntaxWarning: The publisher should be created with an explicit keyword argument 'queue_size'.

dfk gravatar imagedfk ( 2015-03-10 11:26:32 -0500 )edit

Hmm. Ran it again and got this error. I don't understand what could be causing such different errors.

dfk gravatar imagedfk ( 2015-03-10 11:41:00 -0500 )edit

bondpy.py warning is created by http://wiki.ros.org/bondpy . I have confirmed that it does not cause any problem.

jihoonl gravatar imagejihoonl ( 2015-03-15 21:04:46 -0500 )edit

1 Answer

Sort by ยป oldest newest most voted
1

answered 2015-03-10 15:12:56 -0500

dfk gravatar image

Oops. My network settings were not correct. It's all fixed.

edit flag offensive delete link more

Comments

Thanks for the follow up. With my +1 now you can accept your answer (with the checkmark at left) so others know it's solved.

tfoote gravatar imagetfoote ( 2015-03-10 16:08:57 -0500 )edit

It says I need >25 points to accept my own answer...

dfk gravatar imagedfk ( 2015-03-10 17:38:20 -0500 )edit

Sorry I read the wrong field. I lowered it to 10. You should be good now.

tfoote gravatar imagetfoote ( 2015-03-10 18:38:10 -0500 )edit

Stupid question time: which network settings?

Will Chamberlain gravatar imageWill Chamberlain ( 2018-07-03 06:20:14 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2015-03-10 11:21:21 -0500

Seen: 452 times

Last updated: Mar 10 '15