Ask Your Question
0

NavStack Robot Moves Backwards

asked 2015-02-19 16:38:46 -0500

Pototo gravatar image

updated 2015-02-19 16:39:17 -0500

Hi Folks,

When my robot is trying to avoid an obstacle, it tends to move backwards. How can I disable that option so that the robot only have forward velocity, and rotational velocity?

Thanks

edit retag flag offensive close merge delete

Comments

1

What local planner are you using?

David Lu gravatar imageDavid Lu ( 2015-02-19 17:10:51 -0500 )edit

1 Answer

Sort by ยป oldest newest most voted
0

answered 2015-02-25 16:28:29 -0500

Pototo gravatar image

I need need to disable the escape velocity, which causes the robot to move backwards when stuck.

Just went inside:

base_local_planner_params.yaml

and added this parameter:

escape_vel: 0.0
edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2015-02-19 16:38:46 -0500

Seen: 119 times

Last updated: Feb 25 '15